:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sun Sep 23, 2018 12:48 pm
All times are UTC + 0
 Forum index » Featured Tools » Voxel Section Editor III » Bug Reporting
[1.39 rev. 238] Color bug
Moderators: stucuk
Post new topic   Reply to topic Page 1 of 1 [4 Posts] View previous topic :: View next topic
Author Message
Reaperrr
Commander


Joined: 26 Apr 2003
Location: Somewhere in Germany

PostPosted: Thu Feb 18, 2010 4:37 pm    Post subject:  [1.39 rev. 238] Color bug Reply with quote

Banshee, I have following problems with the latest version(s):

1) The text not just on the three editing perspectives, but on many other parts is yellow, and almost impossible to read. it's not that I need it (I know what the items do afterall), but it's very annoying.

2) Nothing important, but the FPS-display on the preview window is too far up and therefore almost hidden on the latest build.

3) The only thing that could really be considered a bug: The color preview doesn't work, neither the one below the palette nor the one in the 'replace colors' dialog. Makes it difficult to compare similar colors.

See also below:


problems1.gif
 Description:
 Filesize:  52.75 KB
 Viewed:  2277 Time(s)

problems1.gif



Back to top
View user's profile Send private message Send e-mail
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Thu Feb 18, 2010 6:12 pm    Post subject: Reply with quote

1) The program is clearly programmed to change the background of these labels to Navy and the text to Yellow.

The code is SetIsEditable function in FormMain,

Code:
   if iseditable then
   begin
      for i := 0 to 2 do
      begin
         lblView[i].Color := clNavy;
         lblView[i].Font.Color := clYellow;
         lblView[i].Refresh;
      end;

      lblSection.Color := clNavy;
      lblSection.Font.Color := clYellow;
      lblTools.Color := clNavy;
      lblTools.Font.Color := clYellow;
      lblPalette.Color := clNavy;
      lblPalette.Font.Color := clYellow;
      lbl3dview.Color := clNavy;
      lbl3dview.Font.Color := clYellow;
      lblLayer.Color := clNavy;
      lblLayer.Font.Color := clYellow;
      lblBrush.Color := clNavy;
      lblBrush.Font.Color := clYellow;


I have no clue why only the text changes to yellow. There is nothing else that changes the colour of the background of these labels back to grey.


2) The FPS text is written by the renderer inside the panel and not above it.


3) The colour preview works correctly here as well.



I think your windows was bugged by something else and that reflected directly in the program. Try restarting your pc and see if these things still happen. If they do, then your windows theme is screwed up, because these problems only happen in your machine and are beyond my control (since it contradicts the code of the program).


And finally, the code for these 3 features are untouched since the Voxel Section Editor III 1.0.

Last edited by Banshee on Thu Feb 18, 2010 6:14 pm; edited 1 time in total

Back to top
View user's profile Send private message Visit poster's website Skype Account
Crimsonum
Seth


Joined: 14 Jul 2005
Location: Fineland

PostPosted: Thu Feb 18, 2010 6:13 pm    Post subject: Reply with quote

I have the same thing with the yellow text and bright background. It would be nice to have a darker background, as I hate bright ones myself.
_________________


Back to top
View user's profile Send private message Visit poster's website
Reaperrr
Commander


Joined: 26 Apr 2003
Location: Somewhere in Germany

PostPosted: Thu Feb 18, 2010 8:35 pm    Post subject: Reply with quote

Banshee wrote:
I think your windows was bugged by something else and that reflected directly in the program. Try restarting your pc and see if these things still happen. If they do, then your windows theme is screwed up, because these problems only happen in your machine and are beyond my control (since it contradicts the code of the program).


And finally, the code for these 3 features are untouched since the Voxel Section Editor III 1.0.


I was afraid the answer would be something like that Sad

Yes, switching to the classic Windows theme fixed things. Which I'm a bit sad about, because my custom theme looked so much better...

Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [4 Posts] View previous topic :: View next topic
 Forum index » Featured Tools » Voxel Section Editor III » Bug Reporting
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
Quick Reply
Username:


If you are visually impaired or cannot otherwise answer the challenges below please contact the Administrator for help.


Write only one of the following words: Brotherhood, unity, peace! 

 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1441s ][ Queries: 14 (0.0180s) ][ Debug on ]