:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sat Jun 23, 2018 9:48 am
All times are UTC + 0
 Forum index » Modding Central » Game Development and Programming Discussion
Latest NET framework
Moderators: Global Moderators
Post new topic   Reply to topic Page 1 of 1 [8 Posts] View previous topic :: View next topic
Author Message
tekka warrior
Stealth Laser Trooper


Joined: 21 May 2012
Location: Beirut,Lebanon

PostPosted: Thu May 02, 2013 11:46 am    Post subject:   Latest NET framework Reply with quote

Hello!

Does anyone know what is the newest version of net framework?

cause after some googling i remained confused.

Thanks!

Back to top
View user's profile Send private message
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Thu May 02, 2013 11:53 am    Post subject: Reply with quote

for what OS?
WinXP: 3.5
Win7: 4.5
Win8: ask Bill Gates
_________________
SHP Artist of Twisted Insurrection:  Nod buildings

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant, 1 Scrin unit, 1 GDI building

Tools
Image Shaper______TMP Shop______C&C Executable Modifier

Back to top
View user's profile Send private message
Graion Dilach
Defense Minister


Joined: 22 Nov 2010
Location: Iszkaszentgyörgy, Hungary

PostPosted: Thu May 02, 2013 1:24 pm    Post subject: Reply with quote

WinXP has 4.0, LKO. 4.5 is the latest.

MSVC2008: .NET 3.5 (still supported XP SP2)
MSVC2010: .NET 4.0 (still supported XP SP3)
MSVC2012: .NET 4.5 (only supports Win7 and Win8)

This is how I learnt them.
_________________



AS Discord server: https://discord.gg/7aM7Hm2

Back to top
View user's profile Send private message Visit poster's website ModDB Profile ID
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Thu May 02, 2013 1:39 pm    Post subject: Reply with quote

^^sounds good too. I never tried 4.0 for XP as i heard a lot of bad things about it. Like missing downward compatibility to programs written in .NET 3.5 and other stuff.
_________________
SHP Artist of Twisted Insurrection:  Nod buildings

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant, 1 Scrin unit, 1 GDI building

Tools
Image Shaper______TMP Shop______C&C Executable Modifier

Back to top
View user's profile Send private message
Graion Dilach
Defense Minister


Joined: 22 Nov 2010
Location: Iszkaszentgyörgy, Hungary

PostPosted: Thu May 02, 2013 1:48 pm    Post subject: Reply with quote

That applies to any major .NET version.

2.x isn't backwards compatible with 1.x.
3.x isn't backwards compatible with 1.x or 2.x... etc.

You know, if you'd be right, I couldn't even write Ares code for a long while because I only have Win7 since this Nov or so while Ares already use auto and such C++0x standardized stuff supported only since VC2010.
_________________



AS Discord server: https://discord.gg/7aM7Hm2

Back to top
View user's profile Send private message Visit poster's website ModDB Profile ID
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Thu May 02, 2013 2:45 pm    Post subject: Reply with quote

Graion Dilach wrote:
2.x isn't backwards compatible with 1.x.
3.x isn't backwards compatible with 1.x or 2.x... etc.

huh? You sure can run programs compiled under 2.0 in a 3.5 environment.

What i meant and heard was, that a .NET 3.5 compiled program didn't run under a 4.0 environment, because 4.0 missed some basic 3.5 libraries.
_________________
SHP Artist of Twisted Insurrection:  Nod buildings

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant, 1 Scrin unit, 1 GDI building

Tools
Image Shaper______TMP Shop______C&C Executable Modifier

Back to top
View user's profile Send private message
tekka warrior
Stealth Laser Trooper


Joined: 21 May 2012
Location: Beirut,Lebanon

PostPosted: Thu May 02, 2013 3:11 pm    Post subject: Latest NET framework Reply with quote

Thank you for replying.

My OS win 7 64-bit, so 4.5 would be the newest, cause im trying to run C&C 3 tiberium wars, and EA told me to get the latest NET framework.

Back to top
View user's profile Send private message
^Rampastein
Rampastring


Joined: 11 Oct 2008
Location: Gensokyo

PostPosted: Thu May 02, 2013 3:17 pm    Post subject: Reply with quote

Lin Kuei Ominae wrote:
What i meant and heard was, that a .NET 3.5 compiled program didn't run under a 4.0 environment, because 4.0 missed some basic 3.5 libraries.

I've never encountered such issues although I used XP (with Visual Studio 2010) for most of my programming from 2010 to 2012. AFAIK .NET isn't backwards compatible, but that's not really a problem since you can have multiple versions installed at the same time.
_________________

Back to top
View user's profile Send private message ModDB Profile ID Facebook Profile URL
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [8 Posts] View previous topic :: View next topic
 Forum index » Modding Central » Game Development and Programming Discussion
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
Quick Reply
Username:


If you are visually impaired or cannot otherwise answer the challenges below please contact the Administrator for help.


Write only one of the following words: Brotherhood, unity, peace! 

 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1392s ][ Queries: 11 (0.0111s) ][ Debug on ]