:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sat Aug 18, 2018 1:12 pm
All times are UTC + 0
 Forum index » PPM Zone » PPM Discussion Zone
Google Chrome no longer supports NPAPI
Moderators: Global Moderators
Post new topic   Reply to topic Page 1 of 1 [7 Posts] View previous topic :: View next topic
Author Message
daTS
Mr. Moosey


Joined: 18 Feb 2005
Location: Star Kingdom of Manticore

PostPosted: Thu Sep 03, 2015 3:31 am    Post subject:  Google Chrome no longer supports NPAPI
Subject description: Which means all of the current sounds no longer play
Reply with quote

Okay, as the title and description state, As of yesterday (1 SEPT 2015) Google Chrome stopped support of older plugin support altogether (meaning they no longer work at all) of older NPAPI plugins.

Google Chrome's Website wrote:
Plugins that use NPAPI, including Silverlight, Java, and Unity, won’t work. If you want to use a website that uses an NPAPI plugin, you’ll need to use a different web browser.


This means all of the sound bites posted (and all the non-youtube) also don't work, seeing as phpbb still uses quicktime's successor. The sound player used by phpbb is an NPAPI plugin.

Is there any way to update the forum plugin software to use newer Pepper API (PPAPI) plugin formats? I'd rather not change browsers since Chrome is integrated into pretty much all of my platforms.
_________________
"Reality is a lovely place, but I wouldn't want to live there." -Adam Young
Founder - Savage Media Group

Back to top
View user's profile Send private message Send e-mail Visit poster's website Skype Account
MadHQ
Commander


Joined: 07 Nov 2003

PostPosted: Thu Sep 03, 2015 5:30 am    Post subject: Reply with quote

Cant you just do this?

http://www.ghacks.net/2015/04/15/chrome-42-blocks-java-silverlight-other-plugins-by-default-now/
_________________
MadHQ's Graveyard - Click here!
(Permissions) - (F.A.Q.)

Back to top
View user's profile Send private message Skype Account
badbully
Grenadier


Joined: 03 Jul 2015
Location: between heaven and hell "the healln point"

PostPosted: Thu Sep 03, 2015 1:00 pm    Post subject: Reply with quote

who in the hell anyways uses chrome I prefer Microsoft edge.
_________________

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Thu Sep 03, 2015 1:44 pm    Post subject: Reply with quote

Thanks for warning me about this problem, DaTS. I've done some changes to the forums. It should use the HTML5 audio controls by default now in most themes, except ptifo.

However, I'm still playing with these settings because Firefox and Chrome does not play wma sounds with HTML5 audio and Internet Explorer 11 does not accept HTML audio at all and doesn't show the old player.

Back to top
View user's profile Send private message Visit poster's website Skype Account
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Fri Sep 18, 2015 5:07 am    Post subject: Reply with quote

Ok, after a hard work on this issue, I'm done with it.

MP3 and WAV files now use HTML5 audio component, while WMA files still relies on Windows Media Player (and compatible) plugin.

So, Chrome should preview MP3 and WAV. In order to preview WMA, install a plugin.

Internet Explorer 9+ previews MP3 and WMA. Old Internet Explorers only previews WMA. In order to preview WAV, change your browser (Edge works fine with WAV)

All other browsers works fine, as long as you have a windows media player plugin for WMA files.


Note that every browser allows you to download these files. So, if your browser doesn't fully support the technology used in these forums, you can still download the sounds and hear them with your favorite player.

Back to top
View user's profile Send private message Visit poster's website Skype Account
daTS
Mr. Moosey


Joined: 18 Feb 2005
Location: Star Kingdom of Manticore

PostPosted: Fri Sep 18, 2015 5:35 am    Post subject: Reply with quote

Awesome. Did you manage to get it to work with ptifo? Or does that theme still not utilize it yet?
_________________
"Reality is a lovely place, but I wouldn't want to live there." -Adam Young
Founder - Savage Media Group

Back to top
View user's profile Send private message Send e-mail Visit poster's website Skype Account
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Fri Sep 18, 2015 1:54 pm    Post subject: Reply with quote

I've got it to work for all themes.

Back to top
View user's profile Send private message Visit poster's website Skype Account
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [7 Posts] View previous topic :: View next topic
 Forum index » PPM Zone » PPM Discussion Zone
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
Quick Reply
Username:


If you are visually impaired or cannot otherwise answer the challenges below please contact the Administrator for help.


Write only one of the following words: Brotherhood, unity, peace! 

 
You cannot post new topics in this forum
You can reply to topics in this forum
You can edit your posts in this forum
You can delete your posts in this forum
You can vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1327s ][ Queries: 12 (0.0211s) ][ Debug on ]