:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sun Dec 16, 2018 3:44 pm
All times are UTC + 0
 Forum index » Modding Central » Tiberian Sun Editing Forum » Mapping Discussion
Weird horizontal shadow glitch
Moderators: Global Moderators, Tiberian Sun Moderators
Post new topic   Reply to topic Page 1 of 1 [6 Posts] View previous topic :: View next topic
Author Message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Thu Apr 06, 2017 3:08 pm    Post subject:  Weird horizontal shadow glitch
Subject description: Help appreciated
Reply with quote

During many tests of my map, I have sometimes (twice yet) found weird glitched shadows/height on horizontal line cross whole map (pics bellow). It happened randomly during game and only 1 glitched line on map. Everything placed on this line (cliffs, buildings, slopes) have some graphical glitch. Location of this line is not firm, it changes sometimes when moving screen sight out.
This glitch is not permanent, saving and reloading remove this glitch, or quick screen moving using V or F9 - F12 changes position of this glitch or removes it completely. I have also noticed this glitch on TS map Stormy Valley rarely after some hours of gameplay.
Has somebody ecountered this glitch? Or anything what can cause it?
(Sorry for dark pictures, happened during night)


SCRN4.png
 Description:
 Filesize:  107.71 KB
 Viewed:  1042 Time(s)

SCRN4.png



SCRN3.png
 Description:
 Filesize:  282.82 KB
 Viewed:  1042 Time(s)

SCRN3.png



SCRN2.png
 Description:
 Filesize:  278.97 KB
 Viewed:  1042 Time(s)

SCRN2.png



SCRN1.png
 Description:
 Filesize:  294.02 KB
 Viewed:  1042 Time(s)

SCRN1.png



Back to top
View user's profile Send private message
TAK02
Commander


Joined: 28 Jun 2015
Location: It was Damascus.

PostPosted: Thu Apr 06, 2017 6:03 pm    Post subject: Reply with quote

I'll jump the gun and say the map is buggy
If it isn't that then something must be wrong with either the EXE you have (from recent engine-hacks maybe?) or it's the terrain INIs (in this case it would be temperat.ini). Other than that I have no idea why the engine would freakout like this
Although, it could be a RAM/memory problem, but I doubt it
_________________
One and only developer of C&C S. True Supremacy.
Youtube: C&C Supremacy Mod | Skype: TAK02 Supreme CnC Mods
m7 wrote:
I tend to release things I create so that assets are never lost to hard drive problems, accidental deletion, or me having to pretend to care about rippers taking things from my project when it is done. #Tongue
I once ninja'd MigEater #Tongue
Back to top
View user's profile Send private message Send e-mail Visit poster's website ModDB Profile ID Skype Account
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Thu Apr 06, 2017 7:19 pm    Post subject: Reply with quote

TAK02 wrote:
I'll jump the gun and say the map is buggy
If it isn't that then something must be wrong with either the EXE you have (from recent engine-hacks maybe?) or it's the terrain INIs (in this case it would be temperat.ini). Other than that I have no idea why the engine would freakout like this
Although, it could be a RAM/memory problem, but I doubt it

I do have modified EXE but only with common hacks (TS Client + tiberium and VeryHigh projectile height), but I don't think it can mess up with rendering. Also temperat.ini is untouched. First time I encountered it was with vanilla TS about 12 years ago on Stormy Valley map, but it was permanent and reloading didn't help. I suspect it has to do something with terrain height or deformation. When I looked in FS and opened Strm. Vall. map, edges of map had unfinished height lines.

Back to top
View user's profile Send private message
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Thu Apr 06, 2017 7:24 pm    Post subject: Reply with quote

What's the height level you're using?
The max 2 to 3 height levels (12-14) can cause such ugly bugs. So it's better to use the lower heights 0-11 only

Though usually this only causes complete black holes in the tiles of the highest map levels, which is quite different to your issue.

Do you modified your game in any way?
Changes in the inis can cause strange bugs too.
e.g. a missing hva for a spawned voxel debris can cause the craziest render fragments.
corrupt mix files can cause such effects too

Are you using the client?
If yes, try some different renderer.

Do you have a map where you can reproduce this bug every single time, which you can upload for others to check? Or is this rather randomly appearing?
_________________
SHP Artist of Twisted Insurrection:  Nod buildings

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant, 1 Scrin unit, 1 GDI building

Tools
Image Shaper______TMP Shop______C&C Executable Modifier

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Thu Apr 06, 2017 7:35 pm    Post subject: Reply with quote

Lin Kuei Ominae wrote:
What's the height level you're using?
The max 2 to 3 height levels (12-14) can cause such ugly bugs. So it's better to use the lower heights 0-11 only
Though usually this only causes complete black holes in the tiles of the highest map levels, which is quite different to your issue.

Could be it, I have max level 13 in map. I will do some tests

Lin Kuei Ominae wrote:

Do you modified your game in any way?
Changes in the inis can cause strange bugs too.
e.g. a missing hva for a spawned voxel debris can cause the craziest render fragments.
corrupt mix files can cause such effects too

I have modified, but this is surely map related, I have run hundreds of games on all maps without this issue (except rarely Stormy Valley).
Lin Kuei Ominae wrote:

Are you using the client?
If yes, try some different renderer

I will try that too, Thanks for suggestions

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Mon Apr 10, 2017 5:36 pm    Post subject: Reply with quote

Tuc0 wrote:
Lin Kuei Ominae wrote:
What's the height level you're using?
The max 2 to 3 height levels (12-14) can cause such ugly bugs. So it's better to use the lower heights 0-11 only
Though usually this only causes complete black holes in the tiles of the highest map levels, which is quite different to your issue.

Could be it, I have max level 13 in map. I will do some tests


So after many days of testing I can confirm that max height caused this glitch. I have removed all 3rd level cliffs (9-13 height) and glitch never appeared again.
Thanks again for all suggestions  Smile  
Map will be released soon.

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [6 Posts] View previous topic :: View next topic
 Forum index » Modding Central » Tiberian Sun Editing Forum » Mapping Discussion
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1401s ][ Queries: 17 (0.0090s) ][ Debug on ]