:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Thu Dec 14, 2017 3:28 pm
All times are UTC + 0
 Forum index » Other Projects » Alpha Projects » Medieval Warfare » Bugs
Crash
Moderators: CombinE, flamewh33l
Post new topic   Reply to topic Page 1 of 1 [7 Posts] View previous topic :: View next topic
Author Message
OmegaBolt
President


Joined: 21 Mar 2005
Location: York, England

PostPosted: Sun Jul 23, 2017 12:24 pm    Post subject:   Crash Reply with quote

Received a crash after I sold a bunch of basic huts (not sure of the name). Attached the debug and exception logs.

I also noticed some odd behaviour with those guys that get sent out to lay the foundations for new buildings. May have been because it was on the very edge of the build radius but they would just run up to the construction and run back without adding any progress.


mwcrash-230717.zip
 Description:

Download
 Filename:  mwcrash-230717.zip
 Filesize:  14.01 KB
 Downloaded:  5 Time(s)


_________________
TAK02 wrote:
Screw AttachEffect. Can't think of any use for it.

Back to top
View user's profile Send private message Send e-mail Skype Account
flamewh33l
Civilian


Joined: 13 May 2017

PostPosted: Sun Jul 23, 2017 12:47 pm    Post subject: Reply with quote

hi OmegaBolt: can you post us the exception and version of the mod that you're playing?

Back to top
View user's profile Send private message
CombinE
Vehicle Driver


Joined: 21 Jan 2017

PostPosted: Sun Jul 23, 2017 12:53 pm    Post subject: Reply with quote

Thanks for you reply,
could you reproduce the crash?
wich building had the problem with the labourors?

Back to top
View user's profile Send private message
OmegaBolt
President


Joined: 21 Mar 2005
Location: York, England

PostPosted: Sun Jul 23, 2017 12:58 pm    Post subject: Reply with quote

The exception is supplied as well as the debug log in the attachment. It was with the version of the mod that was uploaded today.

The building that had the issue with the workers was a hut (playing as the Sultan).

Sorry but I'm not going to try reproduce the crash, I think that's your responsibility. #Tongue
_________________
TAK02 wrote:
Screw AttachEffect. Can't think of any use for it.

Back to top
View user's profile Send private message Send e-mail Skype Account
CombinE
Vehicle Driver


Joined: 21 Jan 2017

PostPosted: Sun Jul 23, 2017 1:01 pm    Post subject: Reply with quote

Im already on it,
i cannot reproduce both of your problems. i think it needs further testing.

Back to top
View user's profile Send private message
OmegaBolt
President


Joined: 21 Mar 2005
Location: York, England

PostPosted: Sun Jul 23, 2017 2:44 pm    Post subject: Reply with quote

Well it is crashing here: https://github.com/OpenRA/OpenRA/blob/bleed/OpenRA.Mods.Common/Traits/KillsSelf.cs#L56

There's not that many KillsSelf references to look through when I searched your files.
_________________
TAK02 wrote:
Screw AttachEffect. Can't think of any use for it.

Back to top
View user's profile Send private message Send e-mail Skype Account
CombinE
Vehicle Driver


Joined: 21 Jan 2017

PostPosted: Sun Jul 23, 2017 7:34 pm    Post subject: Reply with quote

Ok, i uploaded a hotfix, wich hopefully fixes the problems!

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [7 Posts] View previous topic :: View next topic
 Forum index » Other Projects » Alpha Projects » Medieval Warfare » Bugs
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1116s ][ Queries: 14 (0.0075s) ][ Debug on ]