:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Tue Sep 25, 2018 12:58 am
All times are UTC + 0
 Forum index » Modding Central » Tiberian Sun Editing Forum » Mapping Discussion
Finally Learning FinalSun, Help Appreciated!
Moderators: Global Moderators, Tiberian Sun Moderators
Post new topic   Reply to topic Page 2 of 2 [100 Posts] View previous topic :: View next topic
Goto page: Previous 1, 2
Author Message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Wed Dec 13, 2017 10:43 pm    Post subject: Reply with quote

I've actually run into that light bug with it staying on the map.
Was wondering what happened. I'll take your advice on all of
it and experiment more with those values. It's very hard to get
a grasp on modding or mapping when no good editor all-in-one
holy-tutorial-guide-book-glossary-thread thing exists.

If there's some hidden list of what everything means in
FinalSun somewhere, I'd like to know about it. Half my issues
are resolved by someone just telling me about a code string or
what a specific term means and does.

By far my biggest hurdle to overcome is just not knowing
what tools I have at my disposal.

I've only been at this for about a week or so. Day 1 I was
frustrated half the time waypoints didn't trigger anything. Then
I discovered locals and celltags. It's just about knowing what I
have to work with. I've made MP and SP maps for Gen ZH
in the past so I came from that knowledge type down to
the TS mechanisms.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Thu Dec 14, 2017 12:54 am    Post subject: Reply with quote

So the way I think I'll have the win/lose system on this one,
I don't think I need a separate power plant with insignificant=yes.
At least not yet. So I've noticed that even after placing some PPs
beyond the blue border, I get no extra power from them. Any advice?

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Thu Dec 14, 2017 1:57 am    Post subject: Reply with quote

Hm, tested and it indeed doesn't give power. You could try to make new building and place it somewhere not accessible. Something like this:
Code:

[BuildingTypes]
NEW1=INVPWR

[INVPWR]
Image=INVISO
Sight=0
Power=1500     ;any power you need
Name=
Selectable=no
Insignificant=yes
Strength=6000
Armor=heavy
TechLevel=-1

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Thu Dec 14, 2017 6:01 am    Post subject: Reply with quote

I've never made anything new. How do I do that exactly? Just inject the code
into my .map and expect it to show up somewhere in the structures tabs? #Tongue
Is it really that simple?

Also just now I found out some buildings like the abandoned factory and WS
logging company buildings ABAN01 / ABAN03 are invisible. Selectable and
destructable, just missing the model.

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Thu Dec 14, 2017 7:05 am    Post subject: Reply with quote

Yes, inject the new code, reload the map and it will show the entry. But to get
graphics also working correctly, you can enter the same in rules.ini as well.
Search for [BuildingTypes] in rules.ini and add your unique ID there and add
the section to the end of the file. The earlier orange lamp was an example.
As mentioned earlier, art/sound etc. should be already present.

For power, you could increase power of existing PP or make new one or
reduce usage of power for all buildings etc. If you change existing stuff, it
affects all playing side/houses. If you make a new non-buildable one and
pre-place it, it will be for the house you are placing for.

ABAN01 etc. are for snow maps, you are making temperate theater map.
-----------------------------
You are already doing good for a week with finalsun.

Main tools for mapping is finalsun and a text editor.

For tunnel plotting use - https://ppmforums.com/viewtopic.php?t=37881
If you have already drawn tunnels with finalsun, fix those with
https://ppmforums.com/viewtopic.php?t=42008

XCC Mixer helps in extracting MIX file content and make your own MIX
files that the game uses. It also converts audio files.

There is a help file in the finalsun folder. That is old but gives basics. It takes
some time to get used to finalsun.

Refer - https://www.modenc.renegadeprojects.com/Category:Map_Information

TSClient link was given which fixes plenty of bugs and makes it easier than
original for modding and mapping. Tutorial section link at PPM was already
given.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Thu Dec 14, 2017 10:46 pm    Post subject: Reply with quote

Ah alright. Editing with Notepad++. I've used XCC Mixer quite a bit in the
past actually and I also contribute to TS Reborn over at W3D Hub. I haven't
tried making tunnels yet but I've read a bit about the issues around it. I've
only placed entrances to tunnels that lead off-map and rigged them with a
delete team trigger for teams on a script that disappear "going into" them.

Okay, so some assets are not meant to work cross-theater. Understood.

Giving more power to just the player house is the way I'd like to go, so I
will stick with trying out the new object method.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 6:26 am    Post subject: Reply with quote

My dropship won't leave. It lands, unloads, and just sits there.
It has a move-to-waypoint to execute after unloading, followed
by a delete-team for the transport itself. But it just lands and
stays put for some reason. Thoughts?

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Fri Dec 15, 2017 6:33 am    Post subject: Reply with quote

Unload script has 4 options, which team members to retain and dispose,
so that further script actions are executed by whom.

Look at 8,n
https://www.modenc.renegadeprojects.com/ScriptTypes/ScriptActions

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 6:58 am    Post subject: Reply with quote

I have it set to split groups 1; keep trans loose units. And it's
not executing the next waypoint move. :/

EDIT: How do I make player-owned light posts repairable?

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Fri Dec 15, 2017 7:32 am    Post subject: Reply with quote

Then check the script and waypoint again, it should work.

By default the player owned buildings are repairable unless set with
Repairable=false or don't have credits to repair. Have you made it
LegalTarget=no, can you select it?

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 7:56 am    Post subject: Reply with quote

What do I need checked on the team checklist below for the dropship?
Cargo is player owned reinforcements.

The light post is selectable but it refuses the repair function. It's crossed off.

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Fri Dec 15, 2017 9:23 am    Post subject: Reply with quote

Not checkboxes, I meant whether your script looks something like

[xxxxxxxx]
Name=Drop off
0=3,20 ; move to waypoint 20
1=8,1      ; unload passengers keeping transport in team
2=3,21    ; tell transport to move to waypoint 21
3=37,0    ; delete from map

Have you used correct script and waypoints, check those. I can't guess
what else could be wrong, not much info. You could also look into
other mission maps that has dropship unloading units.

Share the light post code that you have used.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 9:29 am    Post subject: Reply with quote

That's just it. It's not a the new light post from earlier. I merely
revalued the color hue for the visible green light post and made
it fall under player control as one of the main base buildings.

Dropship code:
Spoiler (click here to read it):
Code:
[01000027]
0=1,DSHP
1=2,MUTANT
2=2,SMECH
3=1,MUTANT3
4=1,MWMN
5=1,MEDIC
Name=REV Dropship
Group=-1

[01000028]
0=3,15
1=8,1
2=3,16
3=37,0
Name=REV Dropship

[01000029]
Max=5
Full=yes
Name=REV Dropship
Group=-1
House=GDI
Script=01000028
Whiner=no
Droppod=no
Suicide=no
Loadable=no
Prebuild=no
Priority=5
Waypoint=O
Annoyance=no
IonImmune=no
Recruiter=no
Reinforce=no
TaskForce=01000027
TechLevel=0
Aggressive=no
Autocreate=no
GuardSlower=no
OnTransOnly=yes
AvoidThreats=no
LooseRecruit=no
VeteranLevel=1
IsBaseDefense=no
OnlyTargetHouseEnemy=no
TransportsReturnOnUnload=yes
AreTeamMembersRecruitable=no

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Fri Dec 15, 2017 9:50 am    Post subject: Reply with quote

Try TransportsReturnOnUnload=no, I can't see anything wrong with
the rest of it.

Just tried a green lamp post and it got repaired.

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Fri Dec 15, 2017 9:51 am    Post subject: Reply with quote

AZ-Stalker wrote:
That's just it. It's not a the new light post from earlier. I merely
revalued the color hue for the visible green light post and made
it fall under player control as one of the main base buildings.

Should work, maybe try changing these:
Code:

OnTransOnly=no  ; not needed
Full=no                ; not needed, this is probably for full weed eaters in Nod campaign
Suicide=yes         ; this should force team to blindly obey script
TransportsReturnOnUnload=no  ; also not needed, you keep transports in team

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 12:09 pm    Post subject: Reply with quote

Like I said, I don't yet know what each parameter setting is
used for so bugs are bound to happen. Thanks for the help,
light post is now repairable and the dropship does its thing
properly! All good.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 3:09 pm    Post subject: Reply with quote

I'm having trouble making up a trigger that initiates a mission
failed endgame after the player sells their own radar building.

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Fri Dec 15, 2017 3:24 pm    Post subject: Reply with quote

A tag can be attached to one or more objects (building, units etc.) and
when those get destroyed (can apply AND or OR condition that is when
all or one of those get destroyed), a destroyed event could trigger an
action which would make the player loose.

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Fri Dec 15, 2017 3:49 pm    Post subject: Reply with quote

AZ-Stalker wrote:
I'm having trouble making up a trigger that initiates a mission
failed endgame after the player sells their own radar building.

I would suggest event "48 Destroyed by anything" , works for destroying, capturing and selling attached building.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 4:48 pm    Post subject: Reply with quote

I think I did use 48 only to realize that it didn't work for selling.
I'll test it out again to make sure I didn't overlook anything if
that's the case as you are suggesting.

Now I've run into my game crashing the moment my off-map
sub-APC taskforces start with their digging to the enemy base.
Pretty simple spawn here as new taskforce (x2), dig to that
waypoint, then unload, keep all, attack. Something I'm missing
with the dig logic perhaps? Something I had to check differently
than the aerial transports maybe?

Spoiler (click here to read it):
Code:

; Tags
01000090=0,Nod ATTACK 6 - SubAPC A 1,01000089
01000103=0,Nod ATTACK 6 - SubAPC B 1,01000102

; Triggers
01000089=Nod,<none>,Nod ATTACK 6 - SubAPC A,0,1,1,1,0
01000102=Nod,<none>,Nod ATTACK 6 - SubAPC B,0,1,1,1,0

; Other
[01000091]
0=1,SAPC
1=3,ENGINEER
2=2,E1
Name=Nod SubAPC A
Group=-1

[01000092]
0=1,SAPC
1=3,CYBORG
2=2,E3
Name=Nod SubAPC B
Group=-1

[01000095]
0=3,55
1=8,0
2=11,8
Name=Nod ATTACK 6 - SubAPC A

[01000096]
0=3,56
1=8,0
2=0,1
Name=Nod ATTACK 6 - SubAPC B


Side note, learning all of this has been tons of fun!
Thanks for the continued support!

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Fri Dec 15, 2017 4:58 pm    Post subject: Reply with quote

Not sure what is cause of crash, but I would suggest looking in first Nod campaign missions, there are couple of "Dig" teams. If nothing helps, the last way you could do that by playing Dig anim on waypoint and spawn SAPC team there after that.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 5:02 pm    Post subject: Reply with quote

I've looked at a few missions already to better emulate it, but
didn't find anything special in their triggers. I'll check again.

But that's a neat idea for a workaround if all else fails, thanks!

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Fri Dec 15, 2017 5:08 pm    Post subject: Reply with quote

Using 8,2 is better with SAPC. Use attack script even with engineers when
with other infantries.

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Fri Dec 15, 2017 5:11 pm    Post subject: Reply with quote

Or "Hunt" mission, it has good results with engineers, units, hijackers.

EDIT: When set lose transports for undeploy, and you want to move SAPC away, you can set additionally local
        variable at the end of script and add trigger:

Event: Local is set
Action: Create team  ; team only with SAPC and script to move away.

And set trigger tag to SAPC team.

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Fri Dec 15, 2017 5:42 pm    Post subject: Reply with quote

Crash may not be related to the triggers. Try the starting point from
within the map or associate a different waypoint for teamtype.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 5:49 pm    Post subject: Reply with quote

I'd like the SubAPCs detectable, hence why I need them
to move and not just pop up as a spawn.

Looks like it crashes at the same time, always around the same scenario time setting. A few cycles are always on the
same spot once it crashes. And the only attack after them are
the two subAPCs. Nothing else from Nod. There's a transport
even but that's way afterwards.

Doing some more testing, but still no luck in figuring it out.
Taskforces and scripts are clean. Triggers spot on. Teams
shoul be okay. No missing waypoint settings or anything.

Going to try rewiring it to see what fires ect.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Dec 15, 2017 5:59 pm    Post subject: Reply with quote

Okay, so far I've found out that even on the map, they don't spawn in. The tiles never change into the full subAPCs. I've
made sure they're clear, as well as their intended destination.
No pavement ect. Very strange.

I keep looking at the Westwood missions and I don't see what they did differently. This should be pretty straightforward.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Sat Dec 16, 2017 12:10 pm    Post subject: Reply with quote

I've fixed the subAPCs just by redoing them, and for a while it worked, and now it's the very same crash at the same location. Doesn't make much sense as they have no dependencies.

But on another note, why isn't this allow me to build medics?
Is it the tech level setting?

Code:
[MEDIC]
Owner=GDI
Prerequisite=BARRACKS


Engi works, but medic doesn't. Any advice? Smile

EDIT, here's the crash log. It's the same thing from before I re-did the APCs.
Code:
Error code: EXCEPTION_ACCESS_VIOLATION

Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Access address:0000006C was read from.
Exception occurred at 0061C7D6

Version 2.03
Internal Version 2.0
Release Build: 10 by STEVE_TALL - 06/05/2000 - 14:27:06
CPU 686, MMX Yes, Vendor: GenuineIntel

Details:
Eip:0061C7D6   Esp:0028F238   Ebp:00000000
Eax:08C23A20   Ebx:0000009B   Ecx:00748348
Edx:0028F24C   Esi:00000000   Edi:0A868270
EFlags:00210246
CS:0023  SS:002b  DS:002b  ES:002b  FS:0053  GS:002b

Bytes at CS:EIP (0061C7D6)  : 8B 7E 6C E8 32 2A EF FF 8B 40 78 8D 54 24 18 52 8B 56 74 50 8B CF E8 4F 3B E4 FF 8B E8 85 ED 74

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Sat Dec 16, 2017 12:37 pm    Post subject: Reply with quote

Medic is already available for GDI and uses GDI barracks as prerequisite.
If playing at techlevel below 4 then change like

[MEDIC]
TechLevel=1

Engineer is available at techlevel 2 itself.

I can't guess what is wrong from the internal error log. Try the event at
some different time to confirm it is what is causing the crash. If you are
still stuck you could share the map.

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Sat Dec 16, 2017 1:56 pm    Post subject: Reply with quote

When exactly your crash appeared?
Start of map? Some trigger event? Random?

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Sat Dec 16, 2017 2:44 pm    Post subject: Reply with quote

So after a lot of testing and poking around, I think I've tracked
it down to a completely unrelated trigger around the same time
frame. The play explosion at trigger that is used to blow open a
cliff had a typo in its warhead option. So that was the issue.
Finally.

Also, I used to have a blank line separating my campaign listing
from the demo missions in the campaign overview. But for some
reason the blank line isn't showing up anymore. My campaign text
starts right after the last demo entry.

Code:
[TSDEMO2]
CD=-1
Scenario=Maps\Missions\TSDEMO2.MAP
FinalMovie=
Description=Demo Mission 2
LongDescription=TS Demo Mission #2 : Clean Sweep
Side=0
SideName=GDI

; Adds an empty line to the list
[EMPTY]
Description=

[...]

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Sat Dec 16, 2017 3:02 pm    Post subject: Reply with quote

You have to change in the list:

[Battles]
...
10=TSDEMO2
11=EMPTY
12=NEWMAP

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Sat Dec 16, 2017 3:48 pm    Post subject: Reply with quote

Fixed. Thanks!

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Sat Dec 16, 2017 4:15 pm    Post subject: Reply with quote

Any way to make the text triggers stay up on the screen for longer?

Or to review a past text message log in the game itself perhaps?
Was that ever in the game? Like a console feed?

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Sat Dec 16, 2017 4:30 pm    Post subject: Reply with quote

You can repeat a trigger in Tag setting at repeated timed event interval
until some condition is met, then can disable the trigger using another
trigger. Look at demo 2 map.

Briefing can be viewed that way, can restate briefing from pause menu.

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Sat Dec 16, 2017 6:05 pm    Post subject: Reply with quote

Ah so no prolonging of the trigger text display time? Oh well.
Just feels a bit too fast to read the line and take it in properly on
anything faster than the fast setting.

So far I've completed 2 singleplayer missions, fully scripted and
playable. I'm having the story build up as I go, so it'll be a neat
little campaign by the end of it.

Pretty happy with my progress for a bit over a week of
learning. Lots of credit goes to all of you that are helping me
along the way of course.

The third mission is going to be a bit harder to make properly,
as I'm stepping into giving the AI more freedom. Can't wait!

Back to top
View user's profile Send private message
^Rampastein
Rampastring


Joined: 11 Oct 2008
Location: Gensokyo

PostPosted: Sun Dec 17, 2017 11:01 pm    Post subject: Reply with quote

AZ-Stalker wrote:
Ah so no prolonging of the trigger text display time? Oh well.


Try changing [AudioVisual] MessageDelay= in your map.

Code:
[AudioVisual]
MessageDelay=5.0         ; time duration of multiplayer messages displayed over map

_________________

Back to top
View user's profile Send private message ModDB Profile ID Facebook Profile URL
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Mon Dec 18, 2017 10:13 am    Post subject: Reply with quote

When changing [AudioVisual] in map, try to check if nothing else from that section hasn't changed. I remember that when I changed anything from [AudioVisual] section in map, I noticed it reset also those values from section.
Code:

ExtraUnitLight=.2           -> changed into 0
ExtraInfantryLight=.2     -> changed into 0
ExtraAircraftLight=.2      -> changed into 0

And units become darker. If you want to change something I do recommend to also copy-paste those keys from rules.ini section.
I am  not sure about behavior of other keys that would change adding AudioVisual, but these 3 keys are noticable.

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Mon Dec 18, 2017 1:41 pm    Post subject: Reply with quote

Only light related keys affect the Extra...Light keys. MessageDelay key
isn't affecting it.

I had to confirm this first as its rules comment says it is for multiplayer
message. Works for SP as well. Time is in minutes, larger values results
in message pile up. 2 minutes or less should be sufficient for one line
text lines.

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Mon Dec 18, 2017 3:25 pm    Post subject: Reply with quote

E1 Elite wrote:
Only light related keys affect the Extra...Light keys. MessageDelay key
isn't affecting it.


Well I am little confused now. I tried to add in map:
Code:

[AudioVisual]
MessageDelay=.8

And it did not affect unit light in Westwood campaign and skirmish maps, but affected custom campaigns and MP maps? Well, I am going to make some more tests to see why it behaves differently.


UnitExtraLight.gif
 Description:
 Filesize:  26 KB
 Viewed:  3471 Time(s)

UnitExtraLight.gif



Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Mon Dec 18, 2017 4:55 pm    Post subject: Reply with quote

I'll look into it as suggested. Thanks!

How would I go about changing the purchase terminal unit
icons? As in putting in my own images for already existing
units. Does that have to be global, as in turning the client
into a mod, or can it be per-map?

Bonus points if anyone has the blank unit and structure
background images from the purchase terminal icons. I
haven't yet looked for them in the game files, so just curious
if I could save some time if anyone already has them
on hand. Or if anyone could tell me where to look first.

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Mon Dec 18, 2017 5:10 pm    Post subject: Reply with quote

AZ-Stalker wrote:

How would I go about changing the purchase terminal unit
icons? As in putting in my own images for already existing
units. Does that have to be global, as in turning the client
into a mod, or can it be per-map?

Sidebar cameos are tied to ART.ini unit's entry, so you can not change unit's icon to something else. Per map you can only change keys that are in RULES.ini , so max you can do about graphical data is with Image= key which will use selected appearance tied with sidebar icon.
But you can share your campaign in zip file as mod where it would have custom ART.ini, RULES.ini, SOUND01.ini and EChacheXX.mix file where you put custom files, such as icons, sound files and SHP files.

EDIT: You can also share those ini's as Firestorm expansion, using artfs.ini, firestrm.ini, aifs.ini.


AZ-Stalker wrote:

Bonus points if anyone has the blank unit and structure
background images from the purchase terminal icons. I
haven't yet looked for them in the game files, so just curious
if I could save some time if anyone already has them
on hand. Or if anyone could tell me where to look first.


https://ppmforums.com/viewtopic.php?highlight=cameo+blank&t=7813

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Fri Jan 05, 2018 9:12 pm    Post subject: Reply with quote

So I've had to take a bit of a brake from my TS mapping journey.
Just felt like leaving a message here that I haven't disappeared
out of the blue. I'm still learning in my spare time. Once I start
running into roadblocks or getting back into it more intensively,
I'll be sure to bump this thread again!

Back to top
View user's profile Send private message
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Wed Jan 10, 2018 12:58 pm    Post subject: Reply with quote

Okay, so I have an issue that is somewhat unrelated
to mapping or modding itself. It's about recording footage.

My recording software records the CLIENT with a "Game is
now in progress" text line, but the sound from the game is
there. If I kill the client once in game, I get a split second
of footage more like a screenshot with a second of sound.

I read somewhere that it might be OpenGL vs DirectX or
something like that causing the issue. As in the software
uses one while the game is on another setting.

You've all been very helpful here, so I'm curious if anyone
knows what might be the cause?

Note: There is no option to tell the software which specific
process/window to record so I'm having trouble telling it
to focus on TS, not the client.

Back to top
View user's profile Send private message
Tuc0
Rocket Cyborg


Joined: 26 Sep 2016
Location: Slovakia

PostPosted: Wed Jan 10, 2018 3:33 pm    Post subject: Reply with quote

I don't have experience recording TS, but I have read somewhere here on PPM, it is quite tricky. I would suggest playing with different game renders and/or running in window mode (game, not client).
Also try search option in PPM, I am sure that topic was mentioned somewhere.

Back to top
View user's profile Send private message
TAK02
Commander


Joined: 28 Jun 2015
Location: It was Damascus.

PostPosted: Wed Jan 10, 2018 3:52 pm    Post subject: Reply with quote

Had some trouble too recording CnCNet RA2. Switched to XWIS then #Tongue
Win10 has a game bar. And look around for recording software, like OBS, oCam, etc.
_________________
One and only developer of C&C S. True Supremacy.
Youtube: C&C Supremacy Mod | Skype: TAK02 Supreme CnC Mods
m7 wrote:
I tend to release things I create so that assets are never lost to hard drive problems, accidental deletion, or me having to pretend to care about rippers taking things from my project when it is done. #Tongue
I once ninja'd MigEater #Tongue
Back to top
View user's profile Send private message Send e-mail Visit poster's website ModDB Profile ID Skype Account
^Rampastein
Rampastring


Joined: 11 Oct 2008
Location: Gensokyo

PostPosted: Wed Jan 10, 2018 4:42 pm    Post subject: Reply with quote

In addition to the recording software, the selected renderer also affects it. I've succesfully recorded TS using OBS with TS-DDRAW as the renderer, and also using Radeon ReLive with DDrawCompat as the renderer (although Radeon ReLive needs a modern AMD GPU, so it might not be an option for you).
_________________

Back to top
View user's profile Send private message ModDB Profile ID Facebook Profile URL
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Wed Jan 10, 2018 5:42 pm    Post subject: Reply with quote

Hmm... how would I go about changing the renderer?
I've looked for the option within the client but I don't
recall seeing one. Is this something I need to edit
in a config file somewhere?

I've searched for a solution prior to asking here, but
opinions have been all over the place as far as I've
read, and depends on the game version and client
at hand.

Back to top
View user's profile Send private message
^Rampastein
Rampastring


Joined: 11 Oct 2008
Location: Gensokyo

PostPosted: Wed Jan 10, 2018 6:07 pm    Post subject: Reply with quote



The current version of the TS client doesn't have DDrawCompat yet.
_________________

Back to top
View user's profile Send private message ModDB Profile ID Facebook Profile URL
AZ-Stalker
Vehicle Drone


Joined: 10 Feb 2015
Location: Croatia

PostPosted: Thu Jan 11, 2018 5:36 am    Post subject: Reply with quote

Sorry! I must have overlooked the setting. I'll run some tests and
see if my footage gets recorded properly. Thank you all for the help
once again, you always seem to come through.

I'll report back if none of those options worked.

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Page 2 of 2 [100 Posts] Goto page: Previous 1, 2
View previous topic :: View next topic
 Forum index » Modding Central » Tiberian Sun Editing Forum » Mapping Discussion
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.3847s ][ Queries: 15 (0.0167s) ][ Debug on ]