:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Tue Dec 12, 2017 12:26 am
All times are UTC + 0
 Forum index » Featured Tools » Voxel Section Editor III
VXLSE III Shaders and ATI video cards.
Moderators: stucuk
Post new topic   Reply to topic Page 1 of 1 [11 Posts] View previous topic :: View next topic
Author Message
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Wed Mar 10, 2010 5:29 am    Post subject:   VXLSE III Shaders and ATI video cards.
Subject description: I cannot test them on ATI cards.
Reply with quote

From the revision 243 onwards, VXLSE III started to use GLSL shaders. At the moment, it only features a phong shader that supports ambient, diffuse and specular effects.

There are a couple of computers here and they all have nVidia video cards. I cannot test these shaders with ATI cards. I've heard that these are more strict when compiling shaders than the ones from nVidia.

So, I hope someone with an ATI card can inform me if it compiles correctly.


If you are willing to help, download the latest beta and make sure you are online when you run the program for the first time, so it can download the shaders for you (no, it's not DRM, I swear Laughing).

Then, load any random voxel and open the 3D preview window or the Modelizer. Once it opens, check the shaders directory.

If it has only 2 files, then it compiled correctly.

If you find files called:

- phong_vertexshader_error.log
- phong_fragmentshader_error.log

Then, please, upload them here, so I can try to figure out what's wrong with it.

These shaders were extensively tested with a nVidia GeForce 7800 GTX and it compiles correctly.

Back to top
View user's profile Send private message Visit poster's website Skype Account
Crimsonum
Seth


Joined: 14 Jul 2005
Location: Fineland

PostPosted: Wed Mar 10, 2010 5:39 am    Post subject: Reply with quote

I have ATI Radeon HD 4870, and it worked fine with me.
_________________


Back to top
View user's profile Send private message Visit poster's website
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Wed Mar 10, 2010 5:42 am    Post subject: Reply with quote

Thanks a lot, Crimsonum. Smile

Back to top
View user's profile Send private message Visit poster's website Skype Account
SMIFFGIG
General


Joined: 03 Mar 2003
Location: Great Britain

PostPosted: Wed Mar 10, 2010 2:53 pm    Post subject: Reply with quote

Im testing on my Radeon X1950

Unrelated but firstly i got a repair dialogue saying I was missing a cursor file which it retrieved - so that was OK

I then got a dialogue saying
Quote:
"Warning: Your hardware does not support GLSL. Models that uses shader effects will not be previewed correctly in this machine."


Followed by

Quote:
"Access violation at address 00000000. Read of address 00000000."


The program then opened
I then went to open a .vxl file and got this error message

Quote:
"Access violation at address 0415B74E in module 'vxlse_III.exe'. Write of address 00000078'

and the voxel didnt load

btw just to be a grammar nazi, but the error message should probably read
Quote:
Warning: Your hardware does not support GLSL. Models that use shader effects will not be previewed correctly on this machine

Not a big deal as the original message is still understandable, just thought id point it out Smile
_________________

Back to top
View user's profile Send private message Send e-mail Skype Account
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Wed Mar 10, 2010 3:15 pm    Post subject: Reply with quote

Then, I have a problem that needs to be fixed, because Radeon X1950 does support OpenGL 2.0 and GLSL, according to ATI's site.

Also, lack of shader support wasn't supposed to cause access violations of any kind.

And I've fixed the error message in my end. Thank you for pointing out my grammar mistakes.


Just wondering... are you using the latest drivers?

Back to top
View user's profile Send private message Visit poster's website Skype Account
Cranium
Defense Minister


Joined: 05 Dec 2009
Location: USA

PostPosted: Wed Mar 10, 2010 5:14 pm    Post subject: Reply with quote

If the ATI site says his model of vid card supports GLSL then more than likely his drivers maybe out dated.
_________________

The enemy shall be injected with toxic poison - Venom

Back to top
View user's profile Send private message Visit poster's website Skype Account
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Wed Mar 10, 2010 5:19 pm    Post subject: Reply with quote

Yea, his card supports Shader Model 3.0, which is much more than what I use. So, it's either that or the way I'm detecting GLSL support isn't enough. I'm trying to attack both problems.

Back to top
View user's profile Send private message Visit poster's website Skype Account
Cranium
Defense Minister


Joined: 05 Dec 2009
Location: USA

PostPosted: Wed Mar 10, 2010 6:39 pm    Post subject: Reply with quote

just out of curiousity I wanted to see if my vid card supports this, The only error that I recieved was at the begining of the install where it said it couldnt find something, but to click ok to download form the internet. I did that and the program started right up, but where do I find the shader files? here is a pic with the 3d viewer open, but i dont see anything for shaders.


VxlseIII.png
 Description:
 Filesize:  75.03 KB
 Viewed:  5976 Time(s)

VxlseIII.png



_________________

The enemy shall be injected with toxic poison - Venom

Back to top
View user's profile Send private message Visit poster's website Skype Account
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Wed Mar 10, 2010 6:48 pm    Post subject: Reply with quote

The message you get at the start will happen to every user, because I've added shaders to the program and nobody downloaded them before. So, don't worry about it, since the program has already downloaded the shader files for you.

You can play with the shader files at the directory /shaders. I've uploaded them as .txt file, which means that any text editor opens them without complaints. It uses the GLSL language, which reminds C.



And, as I can see in your screenshot, the shaders seem to be working correctly in your machine.

Last edited by Banshee on Wed Mar 10, 2010 6:57 pm; edited 1 time in total

Back to top
View user's profile Send private message Visit poster's website Skype Account
Cranium
Defense Minister


Joined: 05 Dec 2009
Location: USA

PostPosted: Wed Mar 10, 2010 6:54 pm    Post subject: Reply with quote

Ahhh, I found them. This is sweet Banshee! Keep up the awsome work...
_________________

The enemy shall be injected with toxic poison - Venom

Back to top
View user's profile Send private message Visit poster's website Skype Account
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Wed Mar 10, 2010 7:12 pm    Post subject: Reply with quote

Hey SMIFFGIG, try the revision 245 and check if it still gives you a message about no GLSL support.

It includes a special tweak for ATI cards to detect fragment shader support.

Back to top
View user's profile Send private message Visit poster's website Skype Account
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [11 Posts] View previous topic :: View next topic
 Forum index » Featured Tools » Voxel Section Editor III
Jump to:  
Quick Reply
Username:


If you are visually impaired or cannot otherwise play the game below please contact the Administrator for help.


 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1229s ][ Queries: 15 (0.0109s) ][ Debug on ]