:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sun Nov 19, 2017 4:41 pm
All times are UTC + 0
 Forum index » Modding Central » Generals Editing Forum
requesting help with 2 AI problems
Moderators: Generals Moderators, Global Moderators
Post new topic   Reply to topic Page 1 of 1 [9 Posts] View previous topic :: View next topic
Author Message
BionicleManF
Civilian


Joined: 25 Apr 2012

PostPosted: Wed Apr 25, 2012 4:10 am    Post subject:   requesting help with 2 AI problems
Subject description: Superweapon use & Building
Reply with quote

Hello! i am currently working on a mod of mine called BetaMod. It features units and abilities that were forgotten plus a bit of my own tweaks.

I am trying to give the Nuke General AI a special bomb to throw down when at rank 2, i already put it in the AIData.ini but he won't use it
(I am unaware if there is something else i need to do, that goes with the next one too)

and i also want to replace a few of the particle cannons the SupW General AI builds with her other Super weapons (including the Tomahawk Storm i added) again, i eddied the AIData.ini not sure if that was enough.
i know she builds five cannons, I want 3 of those replaced with the 3 other Super weapons of her's.

any help would be most appreciated! Very Happy

Back to top
View user's profile Send private message
Dutchygamer
President


Joined: 18 Jun 2005
Location: Dordrecht, the Netherlands

PostPosted: Wed Apr 25, 2012 6:36 pm    Post subject: Reply with quote

All in the SkirmishScripts.scr. And the only way to edit that is with the WorldBuilder, a pain in the ass.
_________________
Please, read the signature rules of the forum.

Back to top
View user's profile Send private message Send e-mail MSN Messenger
BionicleManF
Civilian


Joined: 25 Apr 2012

PostPosted: Wed Apr 25, 2012 11:50 pm    Post subject: Reply with quote

thanks, but i'll probobly need more info then that.
i have read up how to extract it, but not sure how to continue.

~EDIT~
ok, so i did figure it out all on my own, but this is really confusing, all the generals are in the wrong folders! is that normal?

~EDIT~
oh! i get what went wrong! because i had another team added, everything got messed up! ok, i think i may be able to do it myself!
...
or not. apparently, it still does jumble the players.

Back to top
View user's profile Send private message
Dutchygamer
President


Joined: 18 Jun 2005
Location: Dordrecht, the Netherlands

PostPosted: Sat Apr 28, 2012 6:31 pm    Post subject: Reply with quote

Well, it's really a long story on how to properly edit the AI. Following this tutorial should help something, although I dunno what is causing the problem you describe. Never run into that Confused
_________________
Please, read the signature rules of the forum.

Back to top
View user's profile Send private message Send e-mail MSN Messenger
BionicleManF
Civilian


Joined: 25 Apr 2012

PostPosted: Sat Apr 28, 2012 11:56 pm    Post subject: Reply with quote

what i understood from that is how to get an AI to use units, i need to teach it new buildings.

also, this is what i mean by jumbling the players

as you can see, America has the GLA scrips, and the list above that says China is on the Civilian player.

~EDIT~
OH! i found the source of this problem! plyr civilian need to be at the bottom of the player list! it doesn't do that automatically, removing it from the top and putting it to the bottom has fixed everything! no need for help until further notice! Very Happy

~EDIT~
so i have set up everything in AIData.ini and in SkirmishScripts.scr, but the stuff still wount work.

Back to top
View user's profile Send private message
Dutchygamer
President


Joined: 18 Jun 2005
Location: Dordrecht, the Netherlands

PostPosted: Sat May 05, 2012 4:29 pm    Post subject: Reply with quote

Put the edited SkirmishScripts.scr and AIData.ini in the correct place in your Gen/ZH folder?
_________________
Please, read the signature rules of the forum.

Back to top
View user's profile Send private message Send e-mail MSN Messenger
BionicleManF
Civilian


Joined: 25 Apr 2012

PostPosted: Sun May 06, 2012 5:08 pm    Post subject: Reply with quote

yes, because the buildings i replaced now are not built, but the new buildings aren't built ether

Back to top
View user's profile Send private message
Dutchygamer
President


Joined: 18 Jun 2005
Location: Dordrecht, the Netherlands

PostPosted: Mon May 07, 2012 7:24 pm    Post subject: Reply with quote

Well, that can be a lot of things unfortunately Confused
_________________
Please, read the signature rules of the forum.

Back to top
View user's profile Send private message Send e-mail MSN Messenger
adson3492
Civilian


Joined: 27 Oct 2014

PostPosted: Mon Oct 27, 2014 6:08 am    Post subject: Reply with quote

I have Core i5 quad with tons of RAM and ZH still lags to hell and back. However, it's usually on fan maps with more than 4 players present. The more AIs you throw at the game, the more it has to to pathfind. Pathfinding in ZH is a bitch.

At least on most EA made maps, I can throw every AI at the game and it runs fine. Seems like most fan maps have some sort of pathing issue.
_________________
Cut down your exam stress by db2 certification practice test our latest APPLE exam and high quality New York University and testking mcdst demos.

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [9 Posts] View previous topic :: View next topic
 Forum index » Modding Central » Generals Editing Forum
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1461s ][ Queries: 12 (0.0272s) ][ Debug on ]