:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Wed Apr 08, 2020 12:22 pm
All times are UTC + 0
 Forum index » Modding Central » Red Alert 2 Editing Forum
Trying to add a New Ingame (Sidebar) Video...
Moderators: Global Moderators, Red Alert 2 Moderators
Post new topic   Reply to topic Page 1 of 1 [5 Posts] View previous topic :: View next topic
Author Message
Lee3y
Disk Thrower


Joined: 09 Feb 2018

PostPosted: Thu Oct 10, 2019 12:27 pm    Post subject:  Trying to add a New Ingame (Sidebar) Video...
Subject description: For my soon-to-be-released new campaign mission.
Reply with quote

Greetings everyone,

I'm not sure how many people have done this, or even if anyone has done this, but I'm trying to implement an ingame (sidebar/radar screen) video I have made.

I have already successfully implemented an intro video for this new campaign's 1st mission (currently a placeholder video featuring wildlife!), but this one doesn't seem to want to play....

The into video works as intended; it plays upon selecting the mission, then the loading screen commences.

The ingame video I have, which is created in the same format (.bik), is set to play via a basic trigger. I know the trigger fires, because it is enabled (via action 53 enable trigger) by another trigger, which fires of several triggers, which in turn tells me it's been activated. The trigger which is supposed to play the clip, I called 'Play clip', uses an event of time elapsed '1', and action #100 Play Ingame Movie, referencing the movie index.

I know this is a very, very specific area to delve into, but if anyone has managed any success with sidebar movies, your advice would be appreciated. After all, I would like to make this new campaign as complete as possible.

Back to top
View user's profile Send private message
djohe
Cyborg Informer


Joined: 07 May 2006
Location: Sweden, Gothenburg

PostPosted: Thu Oct 10, 2019 1:20 pm    Post subject: Reply with quote

I have not exactly researched this subject but could your trouble mabe be related to the resolution of the video?

You did not specify what resolution you used in your question about sidebar video and if you used standard video resolution for like full screen vids or if you used a smaller resolution. (always provide as much info as possible so we do not have to guess)

Check what resolution the already existing sidebar videos use.

All I really know is that tiberian sun used much lower resolution for its sidebar .vqa videos compared to the fullscreen .vqa videos.

Back to top
View user's profile Send private message
Lee3y
Disk Thrower


Joined: 09 Feb 2018

PostPosted: Thu Oct 10, 2019 9:35 pm    Post subject: Reply with quote

djohe wrote:
I have not exactly researched this subject but could your trouble mabe be related to the resolution of the video?

You did not specify what resolution you used in your question about sidebar video and if you used standard video resolution for like full screen vids or if you used a smaller resolution. (always provide as much info as possible so we do not have to guess)

Check what resolution the already existing sidebar videos use.

All I really know is that tiberian sun used much lower resolution for its sidebar .vqa videos compared to the fullscreen .vqa videos.


Hi sorry, yes I compared what setting to use with an existing one in game, and as such i scaled my video down to match the resolution (i believe 140x110pixels). Also the other videos in game ppear to be .bik format, rather than .vqa, so i haven't considered trying .vqa. The fullscreen into video was made to match the games other fullscreen vids, scaled down to i believe 800x600. Both videos were originally HD quality, and converted to .bik using the game's corresponding settings (based on existing videos).

Back to top
View user's profile Send private message
djohe
Cyborg Informer


Joined: 07 May 2006
Location: Sweden, Gothenburg

PostPosted: Fri Oct 11, 2019 5:13 am    Post subject: Reply with quote

Ok then I am unsure what the problem is, mabe someone else knows more about .bik videos and if the sidebar versions require anything special to function. All I really know is that it is .bik format (that may or may not need a specific version of RAD Video Tools for compability with RA2/Generals but seeing that you were able to get a fullscreen one to work I do not see why a sidebar one would be causing trouble) and that the movie needs to be listed under [Movies] at the end of artmd.ini for RA2:YR and under [Movies] in art.ini if TibSun/RA2(non YR)

Have you tried to replace one of the already existing sidebar videos (same filename) or any of the fullscreen ones?

Beyond this I do not know anything more and seeing you were able to play the FMV (fullscreen Motion Video) you clearly used the correct .mix file for it.

Back to top
View user's profile Send private message
Lee3y
Disk Thrower


Joined: 09 Feb 2018

PostPosted: Sun Oct 13, 2019 9:31 pm    Post subject: Reply with quote

djohe wrote:
Ok then I am unsure what the problem is, mabe someone else knows more about .bik videos and if the sidebar versions require anything special to function. All I really know is that it is .bik format (that may or may not need a specific version of RAD Video Tools for compability with RA2/Generals but seeing that you were able to get a fullscreen one to work I do not see why a sidebar one would be causing trouble) and that the movie needs to be listed under [Movies] at the end of artmd.ini for RA2:YR and under [Movies] in art.ini if TibSun/RA2(non YR)

Have you tried to replace one of the already existing sidebar videos (same filename) or any of the fullscreen ones?

Beyond this I do not know anything more and seeing you were able to play the FMV (fullscreen Motion Video) you clearly used the correct .mix file for it.


@djohe Apologies for the late reply,

At this stage I can only confirm I have indeed listed the entry correctly to the best of my knowledge. There is no further breakthrough at the moment, however I have not tried replacing an existing video. I don't have much more ideas, so you've at least given me that to think about.

I shall report back here with updates on the matter either way, thank you for your thoughts!

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [5 Posts] View previous topic :: View next topic
 Forum index » Modding Central » Red Alert 2 Editing Forum
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

[ Time: 0.1213s ][ Queries: 10 (0.0137s) ][ Debug on ]