:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::

Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sat May 08, 2021 11:17 pm
All times are UTC + 0
 Forum index » Modding Central » Red Alert 2 Editing Forum
GAPILEDM error and similar
Moderators: Global Moderators, Red Alert 2 Moderators
Post new topic   Reply to topic Page 1 of 1 [2 Posts] View previous topic :: View next topic
Author Message
NimoStar
Cyborg Commando


Joined: 07 Nov 2012
Location: Buenos Aires

PostPosted: Tue Apr 27, 2021 2:20 am    Post subject:  GAPILEDM error and similar
Subject description: Incomprehensible to me
Reply with quote

In my mod, as is common, I have enabled the destruction anims that came with the original game and were unused.

This works fine in GACNSTDM (conyard destruction)

But why does GAPILEDM and GAPRISDM not work with remap? It always shows as red.

Code:
[GAPILEDM]
Remapable=yes
DemandLoad=true
Shadow=yes
;AltPalette=yes      ; use the unit palete
Normalized=yes
NewTheater=yes
Layer=ground
Rate=200

[GACNSTDM]
Remapable=yes
DemandLoad=true
Shadow=yes
;AltPalette=yes      ; use the unit palete
Normalized=yes
NewTheater=yes
Layer=ground
Rate=200


They have the exact same code, actually.

Something is very fishy here.

What do I have to do to make this work correctly?
Fixed anim that someone uploaded somewhere? Or what?

Honestly I can't even know what is wrong to try to fix.

I have tried AltPalette not commented out too.


2021-04-26 23_23_13-SCRN.20210426-232242-00282.BMP - Windows Photo Viewer.png
 Description:
The game hating me
 Filesize:  146.79 KB
 Viewed:  52 Time(s)

2021-04-26 23_23_13-SCRN.20210426-232242-00282.BMP - Windows Photo Viewer.png



_________________

Back to top
View user's profile Send private message Visit poster's website
NimoStar
Cyborg Commando


Joined: 07 Nov 2012
Location: Buenos Aires

PostPosted: Tue Apr 27, 2021 5:09 am    Post subject: Reply with quote

Ok, I found the error... westwood dumbly rendered these animations with Red and Brick colors instead of Remap colors, for whatever reason (they did not make that mistake with all anims)

Unfortunately there is no easy "color switch" solution since attempting it will screw up the explosions colors giving them remap as well, so if anyone has fixed anims, please send the links or them...
_________________

Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [2 Posts] View previous topic :: View next topic
 Forum index » Modding Central » Red Alert 2 Editing Forum
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

[ Time: 0.1448s ][ Queries: 13 (0.0076s) ][ Debug on ]