:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::

Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Fri Jul 30, 2021 3:09 pm
All times are UTC + 0
 Forum index » Modding Central » Red Alert 2 Editing Forum
Something with the dummy building
Moderators: Global Moderators, Red Alert 2 Moderators
Post new topic   Reply to topic Page 1 of 1 [4 Posts] Mark the topic unread ::  View previous topic :: View next topic
Author Message
PePsiCola
Sergeant


Joined: 28 Dec 2010
Location: The United States

PostPosted: Sun May 02, 2021 3:47 am    Post subject:  Something with the dummy building Reply with quote  Mark this post and the followings unread

I did all I could figure to avoid posting this, but after hours of studying different sections of the code, I'm at a loss for what is causing the consistent IE linked to with my dummy building.

In short, it's made for a game mode that makes the AI extremely difficult for the player to face, and part of that includes a dummy building for each faction built shortly after the start that serves as both a CloakGenerator and GapGenerator over their base, Ares Academy settings to make all of their units start at elite status, and a damageless AttachEffect weapon that boosts all unit stats permanently.

Surprisingly, all of that actually works perfectly! Until something decides to crash. The time ingame at which the crash occurs is inconsistent, and I have managed to get through games without a crash too. But now it seems to be happening during every game I test, usually within a minute or two.

The stats are the same for each faction's building, aside from the owner, prerequisite, and AIBasePlanningSide, so I'm just going to share the Allied one.

Code:
[GABUFFY]
Name=Allied AI Buffer
Image=GALITE
;InvisibleInGame=yes
Insignificant=yes
Immune=yes
Selectable=no
Strength=6000
Armor=wood
TechLevel=-1
Nominal=yes
Sight=0
Points=30
Power=0
Crewed=yes
Explosion=TWLT070,S_BANG48,S_BRNL58,S_CLSN58,S_TUMU60
MaxDebris=1
ThreatPosed=0   ; This value MUST be 0 for all building addons
DamageParticleSystems=SparkSys,LGSparkSys
Powered=false
Owner=British,French,Germans,Americans,Alliance
AIBasePlanningSide=0
DontScore=yes
Crewed=no
BuildCat=Tech
Prerequisite=GACNST
Cost=1
Primary=MegaBuffer
AIBuildThis=no ;this is obviously enabled in the game mode
GuardRange=255
DefaultToGuardArea=yes
SpecialThreatValue=1
AIInnerBase=yes
CloakGenerator=yes
CloakRadiusInCells=12
CloakingSpeed=0.5
GapGenerator=yes
GapRadiusInCells=12
Academy.InfantryVeterancy=2.0
Academy.VehicleVeterancy=2.0
Academy.AircraftVeterancy=2.0
Academy.Types= ;huge list of units that doesn't matter for the issue


What I have been able to determine from removing certain elements:
- Academies are not the issue
- The cloak and gap is not the issue
- The weapon is not the issue, even with all its AttachEffect and other settings, so I won't share the weapon code. I know this from giving it a regular combat weapon (which it did fire no problem, but the crash still eventually occured)
-  The InvisibleInGame is not the issue, but removing that was the last thing I tried
- I'm not absolutely certain, but in the last few test matches that didn't crash, the common denominator was having no weapon.

Perhaps dummy buildings (keys such as InvisibleInGame, DontScore, Immune, and Insignificant) cannot have weapons? I have found little discussion of dummy buildings on the forums in my searches, so I have no evidence to confirm that other than my own experience. But maybe it's something else. I have yet to try seeing if removing those helps, but that would defeat the purpose of having a dummy building that super buffed the AI if it actually "existed." DontScore is so the AI can be defeated, of course.

I have 10 identical except.txt files for the crash, so here is the latest one, if anyone can identify the culprit here.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  5.29 KB
 Downloaded:  1 Time(s)


_________________
Tiberium Uprising (a few missions for TS): http://www.ppmsite.com/forum/viewtopic.php?t=31029

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Sun May 02, 2021 4:27 am    Post subject: Reply with quote  Mark this post and the followings unread

Crate anim fails.

Back to top
View user's profile Send private message
PePsiCola
Sergeant


Joined: 28 Dec 2010
Location: The United States

PostPosted: Sun May 02, 2021 2:20 pm    Post subject: Reply with quote  Mark this post and the followings unread

Wow, nothing to do with the building, huh? So the only part of the mode that points to crates is that the player gets no radar, and part of that is disabling map reveal crates. Apparently it didn't like me adding this one line in the game mode INI. Do I have to copy the entire [Powerups] section and adjust from there?

Code:
[Powerups]
Reveal=0,REVEAL,yes


I had time to run one test, and commenting this out yielded no errors, so thank you! But any idea why the game won't allow me to put in that one line without a crate anim fail?
_________________
Tiberium Uprising (a few missions for TS): http://www.ppmsite.com/forum/viewtopic.php?t=31029

Back to top
View user's profile Send private message
E1 Elite
Commander


Joined: 28 May 2013

PostPosted: Tue May 04, 2021 12:29 am    Post subject: Reply with quote  Mark this post and the followings unread

Never tried powerups section in mpmodes or maps but game doesn't allow some entries from rules to be changed while some need related entries to be re declared in maps/mpmodes INI. You could try to put the whole powerups section in mpmodes INI and see if it works.

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [4 Posts] Mark the topic unread ::  View previous topic :: View next topic
 Forum index » Modding Central » Red Alert 2 Editing Forum
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

[ Time: 0.1966s ][ Queries: 13 (0.0106s) ][ Debug on ]