:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Privacy Policy :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::

Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sat May 21, 2022 6:36 am
All times are UTC + 0
 Forum index » Featured Projects » Dawn of the Tiberium Age » Maps
DTA crashes upon running custom map
Moderators: Dawn of the Tiberium Age Staff
Post new topic   Reply to topic Page 1 of 1 [4 Posts] Mark the topic unread ::  View previous topic :: View next topic
Author Message
xX_Pokeman2003_Xx
Civilian


Joined: 24 Jan 2022

PostPosted: Mon Jan 24, 2022 8:11 pm    Post subject:  DTA crashes upon running custom map
Subject description: Attempting to make a custom campaign for DTA. It's not going well, unfortunately.
Reply with quote  Mark this post and the followings unread

Hi all! First post!
I'm trying to make a custom campaign. So far, I've gotten my battle.ini modified, and edited the tutorial.ini to include my new dialog. That's where my successes ended though. Whenever I try to run the map I created, it crashes DTA!
Of course, I went looking around, but I've never seen this error before, and it seems I might be the first one experiencing this error. Here's the short hand error that it throws in.
Quote:
Error code: EXCEPTION_ACCESS_VIOLATION

Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Access address:000000C4 was written to.
Exception occurred at 005E08F0

I've attached both the map and the entire exception log, so that you can try to figure out what's going on.


except.txt
 Description:
Exception log. Hope this is the right one!

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  0 Time(s)


proto.map
 Description:
The map in question.

Download
 Filename:  proto.map
 Filesize:  58.24 KB
 Downloaded:  1 Time(s)


Back to top
View user's profile Send private message
^Rampastein
Rampastring


Joined: 11 Oct 2008
Location: Gensokyo

PostPosted: Thu Jan 27, 2022 1:14 pm    Post subject: Reply with quote  Mark this post and the followings unread

Your map lacks the standard houses. All singleplayer maps need to define the standard houses first, mission-specific houses need to become after them in the map's house list. You can generate the standard houses by pressing the "Standard Houses" button in FinalSun.

Iow. currently your [Houses] list looks like this:

Code:

[Houses]
0=Player
1=Civvie
2=MCV
3=Soviets


It should look like this instead:
Code:

[Houses]
0=GDI
1=Nod
2=Allies
3=Soviet
4=Neutral
5=Special
6=GDI1
7=Nod1
8=GDI2
9=Nod2
10=Allies1
11=Allies2
12=Soviet1
13=Soviet2
14=Player
15=Civvie
16=MCV
17=Soviets


You might also not need your custom houses as you can utilize the standard houses instead.

For the future I recommend joining our Discord server, we're usually online there and you can get help much faster: https://discord.gg/tgUnvd8
_________________
CnCNet Client | CnCNet TS patches | More Quality-of-Life Improvements for RA Remastered


Back to top
View user's profile Send private message ModDB Profile ID Facebook Profile URL
xX_Pokeman2003_Xx
Civilian


Joined: 24 Jan 2022

PostPosted: Tue Feb 01, 2022 3:07 am    Post subject: Reply with quote  Mark this post and the followings unread

^Rampastein wrote:
Your map lacks the standard houses. All singleplayer maps need to define the standard houses first, mission-specific houses need to become after them in the map's house list.

For the future I recommend joining our Discord server, we're usually online there and you can get help much faster: https://discord.gg/tgUnvd8

For the houses:I actually tried this, thinking it might've been the problem. It may be one of the problems I have, but it's not whatever is crashing my map, as you can see from the embedded version that has the original standard houses. Also not shown on the map, but I changed colors around with this variation to ones I absolutely knew were supported by the engine, because I thought maybe peach Nod was responsible. It's not, unfortunately. I also appended the error log for whatever that's worth.
I converted the map to a multiplayer map and it works without issue, so I'm not sure what's going sideways here.

While I appreciate the offer, I absolutely detest Discord, and would prefer the forums over Discord. There's form and function, with the phrase "form over function" often describing such applications, but Discord lacks both of them.


except.txt
 Description:
Yep.

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  2 Time(s)


proto.map
 Description:
The map file. It still crashes.

Download
 Filename:  proto.map
 Filesize:  64.28 KB
 Downloaded:  2 Time(s)


Back to top
View user's profile Send private message
^Rampastein
Rampastring


Joined: 11 Oct 2008
Location: Gensokyo

PostPosted: Sat Feb 05, 2022 10:06 am    Post subject: Reply with quote  Mark this post and the followings unread

The map has triggers owned by a house named "Player", but the house itself does not exist on the map anymore. You need to manually remove any references to a house after you delete it.
_________________
CnCNet Client | CnCNet TS patches | More Quality-of-Life Improvements for RA Remastered


Back to top
View user's profile Send private message ModDB Profile ID Facebook Profile URL
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [4 Posts] Mark the topic unread ::  View previous topic :: View next topic
 Forum index » Featured Projects » Dawn of the Tiberium Age » Maps
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

[ Time: 0.1941s ][ Queries: 13 (0.0110s) ][ Debug on ]