:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sun Nov 19, 2017 6:30 am
All times are UTC + 0
 Forum index » Featured Tools » OS SHP Builder » Bug Reporting
Access violation at address 005252F7
Moderators: stucuk
Post new topic   Reply to topic Page 1 of 1 [9 Posts] View previous topic :: View next topic
Author Message
Matthias M.
Jumpjet Infantry


Joined: 15 Jun 2012
Location: Germany

PostPosted: Sat Jan 04, 2014 10:04 am    Post subject:   Access violation at address 005252F7 Reply with quote

Tried to fix some transparency remap problems in https://github.com/OpenRA/OpenRA/blob/bleed/mods/ra/bits/snipericon.shp with it using SHP Builder 3.37 on Linux with wine version 1.7.7 and can't open any files. In fact this happens with every file and also when clicking New. It looked so promising at first. Sad


SHPbuilder.png
 Description:
 Filesize:  3.77 KB
 Viewed:  1634 Time(s)

SHPbuilder.png



Last edited by Matthias M. on Sat Jan 04, 2014 10:09 am; edited 2 times in total

Back to top
View user's profile Send private message Visit poster's website
Matthias M.
Jumpjet Infantry


Joined: 15 Jun 2012
Location: Germany

PostPosted: Sat Jan 04, 2014 10:06 am    Post subject: Reply with quote

Looks like clicking things in the menu is busted, not the actual SHP loading. Clicking Help → Info also gives those access violations.

Back to top
View user's profile Send private message Visit poster's website
Matthias M.
Jumpjet Infantry


Joined: 15 Jun 2012
Location: Germany

PostPosted: Sat Jan 04, 2014 10:25 am    Post subject: Reply with quote

Forget it. This is fixed in Wine 1.7.9!

Back to top
View user's profile Send private message Visit poster's website
Matthias M.
Jumpjet Infantry


Joined: 15 Jun 2012
Location: Germany

PostPosted: Sat Jan 04, 2014 10:27 am    Post subject: Reply with quote

Scratch that. I still get access violations on load and it takes the whole program down and then the whole desktop environment if you don't kill it fast.

Back to top
View user's profile Send private message Visit poster's website
Matthias M.
Jumpjet Infantry


Joined: 15 Jun 2012
Location: Germany

PostPosted: Sat Jan 04, 2014 10:35 am    Post subject: Reply with quote

Note: I am on a 32-bit machine here.

Back to top
View user's profile Send private message Visit poster's website
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Sat Jan 04, 2014 12:12 pm    Post subject: Reply with quote

I haven't tested the auto-installer with Wine. Did it really download all files?

Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Matthias M.
Jumpjet Infantry


Joined: 15 Jun 2012
Location: Germany

PostPosted: Sat Jan 04, 2014 7:32 pm    Post subject: Reply with quote

I compressed and uploaded the directory the installer created. Looks fine on first impression.


OS SHP Builder.tar.gz
 Description:

Download
 Filename:  OS SHP Builder.tar.gz
 Filesize:  1.55 MB
 Downloaded:  30 Time(s)


Back to top
View user's profile Send private message Visit poster's website
Banshee
Supreme Banshee


Joined: 15 Aug 2002
Location: Brazil

PostPosted: Sat Jan 04, 2014 8:01 pm    Post subject: Reply with quote

The installer has worked correctly.

I don't have any tools that take me to the problematic code that has caused this access violation, specially when it is executed in an emulator. So, I have no idea of what could be causing it at this moment. All I know is that something has tried to access the address pointed by a null pointer.

Today I've done some fixes related to the selection tool and I've added some sanity check codes to deal with unexpected situations without crashing. You can try to update the program to 3.38 Beta 2 to see if it fixes the problem. It can be done by either using the Auto Update feature in the help menu or downloading the 3.38 Beta from the site and replacing SHP_Builder.exe with that one.

Last edited by Banshee on Sun Jan 05, 2014 12:42 pm; edited 1 time in total

Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Matthias M.
Jumpjet Infantry


Joined: 15 Jun 2012
Location: Germany

PostPosted: Sun Jan 05, 2014 10:03 am    Post subject: Reply with quote

I can confirm that this is fixed in 3.38 Beta 2. Great job!

Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [9 Posts] View previous topic :: View next topic
 Forum index » Featured Tools » OS SHP Builder » Bug Reporting
Jump to:  
Quick Reply
Username:


If you are visually impaired or cannot otherwise play the game below please contact the Administrator for help.


 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.2133s ][ Queries: 15 (0.1014s) ][ Debug on ]