:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sat Dec 16, 2017 8:48 am
All times are UTC + 0
 Forum index » Modding Central » OpenRA Editing Forums
Mono is broken.
Moderators: Global Moderators, OpenRA Moderators
Post new topic   Reply to topic Page 1 of 1 [3 Posts] View previous topic :: View next topic
Author Message
SteamsDev
Medic


Joined: 12 Mar 2017

PostPosted: Mon Nov 20, 2017 10:00 pm    Post subject:   Mono is broken. Reply with quote

So, I haven't been on YR or OpenRA until now in which I'm making a new campaign pack completely from scratch. But seeing as I'm here now, I thoguht I'd address a problem with my already corrupt(?) computer.

My mono... is broken.

Surprised  Embarassed  Confused  Shocked  Crying or Very sad  Mad  #Mad

I know, I know, You're all freaking out by this, but before you get too mad at me, let me explain: I've been wanting to try to use mono in a couple situations, such as building a developer copy of OpenRA, but then when I try to make the program itself, this happens:
Code:

steamsdev@latitude-e4310:~/build/OpenRA$ make
Mono is not installed. Please install mono from www.mono-project.com/download/ before building OpenRA
Makefile:249: recipe for target 'fixheader.exe' failed
make: *** [fixheader.exe] Error 1


But there's one problem: my mono is installed. Proof of that was also obtained from the terminal:

Code:

steamsdev@latitude-e4310:~$ mono --version
Mono JIT compiler version 5.0.1.1 (2017-02/5077205 Thu May 25 09:19:18 UTC 2017)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
   TLS:           __thread
   SIGSEGV:       altstack
   Notifications: epoll
   Architecture:  amd64
   Disabled:      none
   Misc:          softdebug
   LLVM:          supported, not enabled.
   GC:            sgen (concurrent by default)


So, I don't know. I'd love your input on this.
_________________
"I'm grade-A, 100%, prime-cut final boss! I'm going to take over the world any day now!"
-Bowser, Super Paper Mario

Official scripting leader of BR Studios
Check out our ModDB: http://www.moddb.com/company/progen-group
Yuri's Revenge: CnCD2K: http://www.moddb.com/mods/red-alert-2-yuris-revenge-cncd2k-mod

Back to top
View user's profile Send private message
SteamsDev
Medic


Joined: 12 Mar 2017

PostPosted: Mon Nov 27, 2017 10:39 pm    Post subject: Reply with quote

I changed the title of this topic so that it had less to do with YR. If one of the admins could move this to where it is fit, that would be much appreciated.
_________________
"I'm grade-A, 100%, prime-cut final boss! I'm going to take over the world any day now!"
-Bowser, Super Paper Mario

Official scripting leader of BR Studios
Check out our ModDB: http://www.moddb.com/company/progen-group
Yuri's Revenge: CnCD2K: http://www.moddb.com/mods/red-alert-2-yuris-revenge-cncd2k-mod

Back to top
View user's profile Send private message
Graion Dilach
Defense Minister


Joined: 22 Nov 2010
Location: Iszkaszentgyörgy, Hungary

PostPosted: Tue Nov 28, 2017 6:21 am    Post subject: Reply with quote

What I tend to do on new Linux installs is to install an OpenRA release first, allowing the package manager itself to set up the dependencies and only thenafter I start selfcompiling and setting up my dev environment. I'm doing this mainly because installing the right Lua version manually is a PITA, though.

Never seen issues with fixheader myself. Which version of OpenRA and Linux distribution is this?
_________________



AS Discord server: https://discord.gg/7aM7Hm2

Back to top
View user's profile Send private message Skype Account
Display posts from previous:   
Post new topic   Reply to topic Page 1 of 1 [3 Posts] View previous topic :: View next topic
 Forum index » Modding Central » OpenRA Editing Forums
Jump to:  
Share on TwitterShare on FacebookShare on Google+Share on DiggShare on RedditShare on PInterestShare on Del.icio.usShare on Stumble Upon
Quick Reply
Username:


If you are visually impaired or cannot otherwise play the game below please contact the Administrator for help.


 
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 0.1310s ][ Queries: 12 (0.0175s) ][ Debug on ]