:: Home :: Get Hosted :: PPM FAQ :: Forum FAQ :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
Do you want to advertise at Project Perfect Mod. Find out how to do it HERE.

The time now is Sun Nov 19, 2017 8:26 am
All times are UTC + 0
 Forum index » Modding Central » Tiberian Sun Editing Forum » HyperPatch
Help: Internal Errors
Moderators: Global Moderators, HyperPatch Moderators, CCHyper
Post new topic   Reply to topic Page 10 of 12 [574 Posts] View previous topic :: View next topic
Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12 Next
Author Message
gouki84
Vehicle Drone


Joined: 16 Mar 2012

PostPosted: Sun Mar 18, 2012 1:42 am    Post subject: Re: Help: Internal Errors Reply with quote

CCHyper wrote:
Ok, this seemed to work pretty well on Tiberium Web, so ill start it here.

If you are receiving Internal Errors, then you may post the except.txt in this topic, but please, help me out by posting what happened when this occurred and if you changed something in particular and you dont know why it did this.

For those who dont know how to get your except.txt, when the game crashes and displays a message box telling you that Tiberian Sun has encountered an internal error, when you see this, quit the game and and goto your Tiberian Sun installation directory, there you will find a file called "except.txt" in the root folder, upload that file to this topic and follow the rules as above.

NOTE: I can not guarantee a fix or cause to your error, so please dont spam this topic.

Hyper


my games randomly crushes all the time i dont know what it is


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  100 Time(s)


Back to top
View user's profile Send private message
Morpher
General


Joined: 28 Jan 2005

PostPosted: Sun Mar 18, 2012 7:41 am    Post subject: Reply with quote

Occurs when playing as GDI and I select a building cameo.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  100 Time(s)


_________________


Back to top
View user's profile Send private message
PJ
Civilian


Joined: 23 Apr 2012

PostPosted: Tue May 22, 2012 3:37 pm    Post subject: Reply with quote

happens when the loading screen gets to creating theories on likely enemy plans.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  106 Time(s)


Back to top
View user's profile Send private message
FurryQueen
General


Joined: 24 Jul 2010

PostPosted: Wed Jun 06, 2012 10:40 pm    Post subject: Reply with quote

There's not much I can do with that address. Could be a broken MIX file. I know I've seen those produce EIPs in that range.
_________________
NZ.org | NZ Gaming | RP
Skype: doctordestiny891
MSN: genkosygin@hotmail.com
Steam

Back to top
View user's profile Send private message
PJ
Civilian


Joined: 23 Apr 2012

PostPosted: Mon Jun 18, 2012 6:12 pm    Post subject: Reply with quote

FurryQueen wrote:
There's not much I can do with that address. Could be a broken MIX file. I know I've seen those produce EIPs in that range.


which one are you referring to?

Back to top
View user's profile Send private message
FurryQueen
General


Joined: 24 Jul 2010

PostPosted: Mon Jun 18, 2012 11:23 pm    Post subject: Reply with quote

The last except you posted. I can't do a whole lot with it.
_________________
NZ.org | NZ Gaming | RP
Skype: doctordestiny891
MSN: genkosygin@hotmail.com
Steam

Back to top
View user's profile Send private message
Hippox77
Civilian


Joined: 28 Jun 2012

PostPosted: Thu Jun 28, 2012 5:57 pm    Post subject: Reply with quote

I get this internal error when playing a custom skirmish with Fog of War on.

Using the 2.3 build, free version from http://cnc-comm.com/. i'm not currently using the Hyperpatch (I don't know how to install it with a no-cd solution, yet)


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  127 Time(s)


Back to top
View user's profile Send private message
FurryQueen
General


Joined: 24 Jul 2010

PostPosted: Fri Jun 29, 2012 9:19 am    Post subject: Reply with quote

That EIP falls outside the range of usable addresses. Since you mention FOW, disable it and see if that fixes the problem. I know it has issues functioning so it's likely that.
_________________
NZ.org | NZ Gaming | RP
Skype: doctordestiny891
MSN: genkosygin@hotmail.com
Steam

Back to top
View user's profile Send private message
Hippox77
Civilian


Joined: 28 Jun 2012

PostPosted: Fri Jun 29, 2012 12:56 pm    Post subject: Reply with quote

FurryQueen wrote:
That EIP falls outside the range of usable addresses. Since you mention FOW, disable it and see if that fixes the problem. I know it has issues functioning so it's likely that.


Yeah, turning off fog does fix the crash related to fog. I already knew that, actually.

Could this issue be something a future Hyperpatch could possible correct? Fog is pretty vital in a proper multiplayer setting, and thus it's a shame it doesn't work on most/many systems.

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Mon Jul 30, 2012 6:01 pm    Post subject: Reply with quote

Happens randomly through TI's campaign, it appears to happen any time it desires, for example: I was playing Nod Mission 2, got half-way, restarted and the second the map loaded up again, IE. I have no idea what's causing it so any light that can be shed would be greatly appreciated.

Edit: It has been narrowed down to Terrain/Overlays, though I'm not entirely sure what the problem is directly.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  80 Time(s)


_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Last edited by Aro on Tue Jul 31, 2012 12:58 am; edited 1 time in total

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Krow
Commander


Joined: 30 Jan 2010
Location: Malaysia

PostPosted: Mon Jul 30, 2012 6:57 pm    Post subject: Reply with quote

Rampastein mentioned that it happened in skirmish too.
_________________
Team Black wrote:
interesting seeing your voxel work. They're still better than Aro's!

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Mon Jul 30, 2012 7:25 pm    Post subject: Reply with quote

Ah, yes. You and Rampa got the same EIP as my one. Well it's good to know that it's the same issue rather than several little ones, but if it's happening so frequently then I'd very much like to eliminate the problem ASAP.
_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Tue Jul 31, 2012 1:33 am    Post subject: Reply with quote

Thanks to the help of Fen, I've found out what was causing the error.

LOBRDGE1 was missing DemandLoad=true from it's art.ini entry and LOBRDG27's image was missing completely from the mix files, fixing both of those issues has prevented this IE from occuring.
_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Paranoia
Cyborg Specialist


Joined: 04 Aug 2007

PostPosted: Wed Aug 08, 2012 4:46 am    Post subject: Reply with quote

Inconsistent error upon game start up.
Its been so long since I've changed anything I've got no clue what its from.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  90 Time(s)


Back to top
View user's profile Send private message
SuperJoe
Commander


Joined: 03 Sep 2009

PostPosted: Tue Aug 14, 2012 3:47 pm    Post subject: Reply with quote

Odd error that occurs every time a map is loading up (any map). Happens at the part when it says "creating theories on likely enemy plan". What makes this IE odd is that it doesn't happen on windows XP, but always happens on windows 7.

Tried different compatibility modes and tried without this method (which I had enabled by default for my mod). Neither works. I am also not using the ddraw.dll, but I am using Hyper's waveclass fix. Even more interesting is the fact that I can run the original TS runs just fine, no problems. So it has to be something in the mod, and something that only causes problems for windows 7.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  84 Time(s)


_________________

Back to top
View user's profile Send private message
Paranoia
Cyborg Specialist


Joined: 04 Aug 2007

PostPosted: Wed Aug 15, 2012 5:56 am    Post subject: Reply with quote

Have you recently added a new mouse.shp?

Back to top
View user's profile Send private message
SuperJoe
Commander


Joined: 03 Sep 2009

PostPosted: Thu Aug 16, 2012 9:55 am    Post subject: Reply with quote

Paranoia wrote:
Have you recently added a new mouse.shp?


Nope, I haven't changed anything in the interface. Tried running the mod with the original game.exe and language.dll, both result in the same IE. So it can't be related to any changes I've made to them either. Really weird. I wonder if a MIX file could be broken in a way that makes the game run fine on XP but crash on win7. Kind of running out of ideas what the hell this could be.
_________________

Back to top
View user's profile Send private message
MrTweek
Cyborg Soldier


Joined: 18 Jul 2012
Location: Germany

PostPosted: Thu Aug 16, 2012 1:39 pm    Post subject: Reply with quote

Quote:
on enemy likely plan
...

on this step, the game is reading the settings/instructions from your INI-Files (rules.ini, ai.ini)...

when you had messed up these files last time, checked for errors... =/

Back to top
View user's profile Send private message
visplaneoverflow
Civilian


Joined: 17 Aug 2012

PostPosted: Sat Aug 18, 2012 12:02 am    Post subject: Reply with quote

This crash occurs frequently and randomly, I think it seems to happen more often when playing versus the AI which indicates to me that the bots are trying to do something impossible, but I think I've seen it happen once or twice in games with no AI players.

Occurs only in Skirmish or multiplayer games, I've never seen the crash during the campaigns.

I'm running a slightly modded version of TS - values have been changed for some units, but there are very few new units or new features. This particular except was captured about 20 seconds into a 4 player Skirmish battle on Pentagram.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  110 Time(s)


Back to top
View user's profile Send private message
MrTweek
Cyborg Soldier


Joined: 18 Jul 2012
Location: Germany

PostPosted: Sat Aug 18, 2012 4:19 am    Post subject: Reply with quote

the Screen is explaining the Situation

Code:

Access address:[b]07DFC890[/b] was read from.
Exception occurred at [b]006703D4[/b]



Sonic-IE.png
 Description:
maybe it is helpfull for CCHyper =(
 Filesize:  27.61 KB
 Viewed:  11679 Time(s)

Sonic-IE.png



WCE_IE.png
 Description:
 Filesize:  486.2 KB
 Viewed:  11692 Time(s)

WCE_IE.png



EXCEPT.TXT
 Description:

Download
 Filename:  EXCEPT.TXT
 Filesize:  20.75 KB
 Downloaded:  99 Time(s)


Back to top
View user's profile Send private message
SuperJoe
Commander


Joined: 03 Sep 2009

PostPosted: Sun Aug 19, 2012 1:45 pm    Post subject: Reply with quote

SuperJoe wrote:
Odd error that occurs every time a map is loading up (any map). Happens at the part when it says "creating theories on likely enemy plan". What makes this IE odd is that it doesn't happen on windows XP, but always happens on windows 7.

Tried different compatibility modes and tried without this method (which I had enabled by default for my mod). Neither works. I am also not using the ddraw.dll, but I am using Hyper's waveclass fix. Even more interesting is the fact that I can run the original TS runs just fine, no problems. So it has to be something in the mod, and something that only causes problems for windows 7.


Managed to isolate the error to my ecache02.mix. Simply deleting it will make the mod run again. One can only guess what's screwed up about it, can't really be that the file is too big cause my ecache03 is 60mb, while ecache02 is 57mb. Even more strange that it doesn't cause errors on WinXP.

How do you other modders manage your MIX files? To me XCC Mix Editor has always been a pain in the ass, it keeps corrupting MIX files randomly. Even if I create a new MIX file, put all the files in once, compact, and then check out and notice a few files are listed as unidentified file type. So then I have to insert those files again, and probably corrupt the MIX file. Also is there a recommended max file size for MIX files, are large MIX files more likely to become corrupted?


EDIT: Maybe someone with the proper skills could make another program to manage MIX files? It sucks that such an important tool for C&C modding is unreliable. Or am I the only one running into problems with it?
_________________

Back to top
View user's profile Send private message
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Sun Aug 19, 2012 1:59 pm    Post subject: Reply with quote

Use XCC Mixer and not the Mix Editor!
XCC Mixer runs pretty stable in the latest version and Olaf is even around on PPM, so you can contact him if the Mixer causes trouble again.

Just start XCC Mixer, open a mix, then drag and drop the files from the windaft explorer into the open XCC Mixer mix file.
_________________
SHP Artist of Twisted Insurrection. Main Nod building SHP creator.

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant unit, 1 Scrin unit, 1 GDI building

Tools
TMP Shop
C&C Executable Modifier

Back to top
View user's profile Send private message
Graion Dilach
Defense Minister


Joined: 22 Nov 2010
Location: Iszkaszentgyörgy, Hungary

PostPosted: Sun Aug 19, 2012 2:51 pm    Post subject: Reply with quote

Never compact with Mix Editor.

Use simple save.
_________________



AS Discord server: https://discord.gg/7aM7Hm2

Back to top
View user's profile Send private message MSN Messenger
FurryQueen
General


Joined: 24 Jul 2010

PostPosted: Mon Aug 20, 2012 6:27 am    Post subject: Reply with quote

I compact with the Mix Editor all the time and have never had an issue with it. I dunno what you guys are doing wrong.
_________________
NZ.org | NZ Gaming | RP
Skype: doctordestiny891
MSN: genkosygin@hotmail.com
Steam

Back to top
View user's profile Send private message
Graion Dilach
Defense Minister


Joined: 22 Nov 2010
Location: Iszkaszentgyörgy, Hungary

PostPosted: Mon Aug 20, 2012 7:52 am    Post subject: Reply with quote

I assume it's something with filesize. I tried to compact a 215 MB mix (still have it if you wanna check) and it went corrupted.

It successfully corrupted my mpmodesmd.ini which was totally awesome then with all those IEs 'til I checked the mix itself. -_-
_________________



AS Discord server: https://discord.gg/7aM7Hm2

Back to top
View user's profile Send private message MSN Messenger
SuperJoe
Commander


Joined: 03 Sep 2009

PostPosted: Wed Aug 22, 2012 2:22 pm    Post subject: Reply with quote

Tried removing files from ecache02.mix one by one, and narrowed down the problem to 3 buildings (CAPYR01.shp - CAPYR03.shp). These are the same pyramid shps from TS, I just added damaged frames for them. First I thought ok maybe theres' some sort of problem with these shps or their entry in art.ini. But nope, added the same shps into ecache03.mix and the mod works perfectly again.

Then tried readding the files back to ecache02, and it crashes again. Finally added some other new stuff to ecache02 along with these SHPs and now it works again. Almost starting to think the problem has something to do with a very specific file size or number of entries in the MIX file. I recall running into this same error long time ago and usually solved it by removing / adding some other stuff into the mix.

I still have no idea though why the crash only happens in windows 7, not in XP.
_________________

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Wed Aug 22, 2012 4:37 pm    Post subject: Reply with quote

Quote:
I still have no idea though why the crash only happens in windows 7, not in XP.


A shot in the dark note since you mentioned they were only the pyramid SHP's, but it's worth stating anyway in case you're unaware: If something uses the tag DemandLoad=true in art.ini, it can cause internal errors if they are placed anywhere else other than isotem.mix.
TI had this issue a while ago, while people using XP didn't get the Internal Error, users on Vista or Windows 7 on the other hand did and had to set the executable to Windows 98 compatibility.
_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
SuperJoe
Commander


Joined: 03 Sep 2009

PostPosted: Wed Aug 22, 2012 6:18 pm    Post subject: Reply with quote

Aro wrote:
Quote:
I still have no idea though why the crash only happens in windows 7, not in XP.


A shot in the dark note since you mentioned they were only the pyramid SHP's, but it's worth stating anyway in case you're unaware: If something uses the tag DemandLoad=true in art.ini, it can cause internal errors if they are placed anywhere else other than isotem.mix.
TI had this issue a while ago, while people using XP didn't get the Internal Error, users on Vista or Windows 7 on the other hand did and had to set the executable to Windows 98 compatibility.


This fixed the problem as well, without having to touch the MIX file. Thanks for the info. Though kind of an odd bug since I got it fixed by messing around with the MIX file as well...

Went ahead and replaced every DemandLoad=true with false, and ended up with this:



Guess the key is needed for stuff that really does reside in isotem / isosno.mix
_________________

Back to top
View user's profile Send private message
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Wed Aug 22, 2012 9:51 pm    Post subject: Reply with quote

let me quote myself from here Smile
Lin Kuei Ominae wrote:
While working on the new staff build i found the reason/solution for the compat problem.

As already assumed in my post above, it's the key DemandLoad and only this key afaik right now.
The reason is, that with DemandLoad=true on a building, the engine tries to load the SHP from iso*.mix and disables its ability to load it from ecacheXX.mix files.

If you set DemandLoad=true and there is no matching SHP in the iso*.mix file that is used for the theater of the currently loading map, the game will crash at the loading screen, even if there is a SHP in an ecacheXX.mix.
If you don't set the key (it's by default false) and there is no SHP in the ecacheXX.mix, the game will load perfectly fine, though the building is invisible ingame, even if there is a SHP in iso*.mix.

In short:
DemandLoad=true: load from iso*.mix. Crash at loading screen when SHP not found.
DemandLoad=false (default): load from ecacheXX.mix. No crash, no problems.

So my advice is to avoid using this key as far as possible as with it, it can cause serious trouble and you have to always be sure that its usage is correct.

DemandLoadBuildup and FreeBuildup don't seem to cause this trouble and can be used, even though i have no real clue what FreeBuildup exactly does.

Without DemandLoadBuildup=true the game seems to be unable to load the buildup from ecacheXX.mix files and tries to load instead from iso*.mix. Though a missing buildup anim in iso*.mix doesn't cause a crash this time.
So this key seems to work the other way round than DemandLoad.

In short:
DemandLoadBuildup=true: load from ecacheXX.mix
DemandLoadBuildup=false (default): load from iso*.mix

_________________
SHP Artist of Twisted Insurrection. Main Nod building SHP creator.

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant unit, 1 Scrin unit, 1 GDI building

Tools
TMP Shop
C&C Executable Modifier

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Fri Oct 05, 2012 1:41 pm    Post subject: Reply with quote

Any ideas on this one, please? It's really starting to get on my nerves.


logfile.txt
 Description:

Download
 Filename:  logfile.txt
 Filesize:  161.12 KB
 Downloaded:  80 Time(s)


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  96 Time(s)


_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Paranoia
Cyborg Specialist


Joined: 04 Aug 2007

PostPosted: Sun Oct 14, 2012 6:06 am    Post subject: Reply with quote

Error occurs at anytime late game. God knows what it is.


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  83 Time(s)


Back to top
View user's profile Send private message
Morpher
General


Joined: 28 Jan 2005

PostPosted: Tue Oct 16, 2012 3:54 am    Post subject: Reply with quote

This is a random occurence, seems to happen on a particular map after loading it for the second time in Skirmish. First attempt at playing on it is fine, second attempt gives me this IE.

(Additionally it seems playing on any map, then this one seems to cause this problem).


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  93 Time(s)


_________________


Back to top
View user's profile Send private message
Crimsonum
Seth


Joined: 14 Jul 2005
Location: Fineland

PostPosted: Tue Nov 27, 2012 9:20 pm    Post subject: Reply with quote

Happens only on temperate maps during loadout. I haven't even touched the temperat.ini.


except.txt
 Description:
EIP:7746748F

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  55 Time(s)


_________________

Twisted Insurrection co-leader

Back to top
View user's profile Send private message Visit poster's website
Reaperrr
Commander


Joined: 26 Apr 2003
Location: Somewhere in Germany

PostPosted: Mon Dec 10, 2012 8:37 pm    Post subject: Reply with quote

Morpher wrote:
This is a random occurence, seems to happen on a particular map after loading it for the second time in Skirmish. First attempt at playing on it is fine, second attempt gives me this IE.

(Additionally it seems playing on any map, then this one seems to cause this problem).

Is it really just that one map, or does the 2nd attempt fail for other maps, too?

I'm asking because I currently have the same bug with ROTD 2.9 beta (but with every map), while the public 2.8.7 is running fine.

OK, I tracked it down to being a rules.ini-related problem, at least in my case. Damn, I have no idea what I did to cause this...


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  89 Time(s)


Back to top
View user's profile Send private message Send e-mail
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Mon Dec 10, 2012 8:50 pm    Post subject: Reply with quote

Check things like your warheads section and other lists.
If these don't contain every used warhead/object, the game loads them fine the first time, but can crash on the second time since it doesn't unloads them correct when closing the map.
_________________
SHP Artist of Twisted Insurrection. Main Nod building SHP creator.

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant unit, 1 Scrin unit, 1 GDI building

Tools
TMP Shop
C&C Executable Modifier

Back to top
View user's profile Send private message
Spectracus
Civilian


Joined: 26 Apr 2013
Location: Finland

PostPosted: Fri Apr 26, 2013 9:16 am    Post subject: Reply with quote

I don't understand this. When i start TS and run any map, it plays fine. When i run a map again (could be any particular map, doesn't have to be the exact same one), it IE:s to "compensating for ambient light values". It started happening after i edited lighting settings on a custom map, even though it sounds odd, it could give a hint toward the problem because it started happening right after that. Thing is, now ALL TS maps do the same trick: work on first try like always but IE on second run. I've never heard of anything like this before. It can also crash after running a campaign mission. Not only that but when i peeked into game files again i noticed that name entries in TS files (an example of MAPS01 is posted below) have changed to a code or something. In addition most of them are now txt. files. Halp, any1? Confused


Untitled.png
 Description:
Sorry for big pic...
 Filesize:  22.12 KB
 Viewed:  9141 Time(s)

Untitled.png



except.txt
 Description:
IE:

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  41 Time(s)


Back to top
View user's profile Send private message
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Fri Apr 26, 2013 12:56 pm    Post subject: Reply with quote

Do you modified your game?
Such a strange bug can happen if you use for example an animation which wasn't listed in the [Animations] list. On a few cases, the anim can work fine on the first run, but cause a crash on the second. I assume the memory allocation has then trouble with the object that is used but not really known by the game.

It might also happen in maps if you use there something like a new warhead which you haven't added to the [Warheads] list.


Those hexadezimal numbers instead of names in XCC Mixer can happen if you delete your "global mix database.dat" file in the XCC Mixer folder or use an older version of that file. Because this is used by XCC to identify the files of the original c&c mix files.
When you create your own mix, XCC stores a "local mix database.dat" inside the mix which has the names of the stored files listed.
_________________
SHP Artist of Twisted Insurrection. Main Nod building SHP creator.

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant unit, 1 Scrin unit, 1 GDI building

Tools
TMP Shop
C&C Executable Modifier

Back to top
View user's profile Send private message
Astor
Cyborg Soldier


Joined: 01 Jan 2010
Location: Austria

PostPosted: Sat Apr 27, 2013 3:49 am    Post subject: Reply with quote

This crash is driving me crazy #Mad

At first I could fix the "random crashes" it was caused by the veteran sight bonus, which produced problems if units with sight 10 got promoted. But the game does still crash. It's a late game crash.

I always check my game for errors with speed 6, revaled map and 7 AI players on hardest difficult (My MCV is cloaked, so they leave me alone). At first I thought it would be a explosion animation (because it crashed 2 times while I saw a building exploding) but there is nothing wrong with them. Also tried with disabled veterancy bonuses. Result was again a late game crash.

When I blow up buildings no crash happens. So what's the reason why it's crashing late game then? I am running out of ideas Sad


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.75 KB
 Downloaded:  27 Time(s)


Back to top
View user's profile Send private message
Spectracus
Civilian


Joined: 26 Apr 2013
Location: Finland

PostPosted: Sat Apr 27, 2013 5:02 am    Post subject: Reply with quote

Looks like i had a warhead missing from the warhead list in rules.ini, and had two 8's in firestrm.ini's buildingtypes list. It works now. Sorry for slight off-topic, but what do i do about the global mix cache? I must have accidentally deleted the old one cleaning the file up...

Back to top
View user's profile Send private message
Lin Kuei Ominae
Seth


Joined: 16 Aug 2006
Location: Germany

PostPosted: Sat Apr 27, 2013 8:12 am    Post subject: Reply with quote

Download the XCC Mixer again. It comes with the global mix database.
_________________
SHP Artist of Twisted Insurrection. Main Nod building SHP creator.

Public SHPs
X-Mech Calendar (28 Mechs for GDI and Nod)
5 GDI, 5 Nod, 1 Mutant unit, 1 Scrin unit, 1 GDI building

Tools
TMP Shop
C&C Executable Modifier

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Wed May 22, 2013 12:59 pm    Post subject: Reply with quote

Eip:004D2451

Eip:004D2451

Eip:004D2451

Eip:004D2451

Somebody, please, crack whatever is causing this IE. It has been driving me insane and putting everything at a standstill for such a long time.


logfile.txt
 Description:

Download
 Filename:  logfile.txt
 Filesize:  29.76 KB
 Downloaded:  44 Time(s)


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  33 Time(s)


_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
AlexB
Cyborg Commando


Joined: 31 May 2010
Location: Germany

PostPosted: Wed May 22, 2013 1:32 pm    Post subject: Reply with quote

Check the VoxelAnims. One voxel anim tries to damage the inhabitants of a cell and apparently has no valid Warhead= set.
_________________

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Wed May 22, 2013 2:56 pm    Post subject: Reply with quote

Thank you for the response, AlexB. Smile I've had a big dig through the INI files and I can't see anything out of the ordinary... I have made some small changes such as entries with more than 8 characters being reduced to less than 8, removal of some unused types and making sure the MaxDebris and DebrisMaximums coincide with eachother on all of the entries.

There wasn't any VoxelAnim entries with a missing warhead or an incorrect warhead, mostly, the defaults are used so I'm not sure what the problem is. Sad
_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
AlexB
Cyborg Commando


Joined: 31 May 2010
Location: Germany

PostPosted: Wed May 22, 2013 3:38 pm    Post subject: Reply with quote

I'm not sure what happened either, but an infantry unit was damaged by a non-existing warhead. Maybe it's not Warhead= on the existing VoxelAnims that is wrong, but a non-existing VoxelAnim is referenced somewhere (which then has no Warhead=). Maybe a typo that automatically adds a new VoxelAnim.
_________________

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Thu May 23, 2013 11:51 am    Post subject: Reply with quote

Another staff member reported the same Eip:004D2451, does it seem to be the same issue? I have scanned the INI's over and over and I can't see a problem.


logfile.txt
 Description:

Download
 Filename:  logfile.txt
 Filesize:  114.35 KB
 Downloaded:  35 Time(s)


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.74 KB
 Downloaded:  26 Time(s)


_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
AlexB
Cyborg Commando


Joined: 31 May 2010
Location: Germany

PostPosted: Thu May 23, 2013 2:16 pm    Post subject: Reply with quote

Yes, same reason. Infantry taking damage from VoxelAnim.
Was it a different map than the first one?
_________________

Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Thu May 23, 2013 2:20 pm    Post subject: Reply with quote

Aye, same map, but we've had the same EIP on various maps in the past.

We went through a sweep of our INI's and found some small oddities which we've now fixed, primarily, replacing any "Warhead=Meteorite" with "Warhead=MeteorWH". For some reason, this exists in stock TS, yet, the EXE and the INI's contain no entries of any kind for the Meteorite warhead. Confused

Other than that, some DebrisMaximums values did not coincide with MaxDebris values. If the error happens again, I'll post again along with the INI's.
_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Morpher
General


Joined: 28 Jan 2005

PostPosted: Thu May 23, 2013 5:27 pm    Post subject: Reply with quote

There's no map specific code going on that'd cause interference?
_________________


Back to top
View user's profile Send private message
Aro
Alcohol Fueled


Joined: 10 Sep 2006
Location: Birmingham, United Kingdom

PostPosted: Thu May 23, 2013 5:41 pm    Post subject: Reply with quote

Not that I can think of because it happens on quite a lot of maps and always at random intervals. In our public IE thread, it is the number one EIP.
_________________


Retired from modding. All the best, PPM!

Twisted Insurrection [Version 0.6]
Twisted Insurrection OST [Vol. 6]
Twisted Insurrection: Gallery

Tiberian Sun Client (Includes UMP)

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Astor
Cyborg Soldier


Joined: 01 Jan 2010
Location: Austria

PostPosted: Sun May 26, 2013 9:05 pm    Post subject: Reply with quote

Save/Load function is broken. I don't know why, any ideas?

Bytes at CS:EIP (0060DC0D)  : F7 7C 24 10 89 44 24 10 85 ED 7F BF 8B 56 04 8D 4E 04 FF 52 0C 8B 46 1C 8D 4E 1C FF 50 0C 5F 5D


except.txt
 Description:

Download
 Filename:  except.txt
 Filesize:  20.67 KB
 Downloaded:  31 Time(s)


_________________


Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic Page 10 of 12 [574 Posts] Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12 Next
View previous topic :: View next topic
 Forum index » Modding Central » Tiberian Sun Editing Forum » HyperPatch
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © phpBB Group

Wildcard SSL Certificates
[ Time: 2.2688s ][ Queries: 17 (1.8591s) ][ Debug on ]